ctrl+shift+t doesn't work any more after update to beta 3

RESOLVED DUPLICATE of bug 531053

Status

()

--
major
RESOLVED DUPLICATE of bug 531053
9 years ago
9 years ago

People

(Reporter: novemberox, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b3) Gecko/20091121 Gentoo Firefox/3.6b3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b3) Gecko/20091121 Gentoo Firefox/3.6b3

When trying to restore closed tab using ctrl+shift+t it just doesn't work. Firefox don't open tab, it looks like shortcut hasn't been pressed.

Reproducible: Always

Steps to Reproduce:
1. open new tab
2. close tab above
3. try to re-open tab using ctrl+shift+t
Actual Results:  
nothing hapens

Expected Results:  
tab should be restored
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4pre) Gecko/20091119 Namoroka/3.6b4pre

The key combination restores the previously closed tab.
Have you tried safe-mode / a new profile?
http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

9 years ago
Nothing has changed. I tried both ways and mixed.
History -> Recently Closed Tabs, is that grayed out?
(Reporter)

Comment 4

9 years ago
Yes they are grayed out, 'recently closed windows' as well.
Component: Keyboard Navigation → Session Restore
QA Contact: keyboard.navigation → session.restore
Do you see anything in your error console? (you might need to change the javascript.options.showInConsole pref to true). Try checking at startup and right after trying to look at the menu.
(Reporter)

Comment 6

9 years ago
Error: uncaught exception: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: chrome://browser/content/browser.js :: delayedStartup :: line 1146"  data: no]

That is the only error I found. I'm not sure if that's related to anything.
Well, Session Restore is initialized in delayedStartup. If you can run this in the error console - |"nsISessionStore" in Components.interfaces| - you'll see true/false output.

If it's true, then there's an error while session restore is being loaded (bad JS) or the file never got loaded (doesn't exist, as the error suggests). Try reinstalling the beta - I don't know how this would happen.

If it's false, then the problem is something else.
Duplicate of this bug: 531258
So I'm 95% sure this is actually a dupe of bug 531053 (which got fixed after beta 4) - especially because of the error in comment #6. Mikolaj, mastacheata - can you try a nightly from today on and see if it's still broken?

Comment 10

9 years ago
After a clean install everything works fine. When importing settings and addons from a previously installed version many things don't work the way they should.
Will try reinstalling my addons one by one now and have a look which one doesn't play nice.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531053
You need to log in before you can comment on or make changes to this bug.