Status

P3
critical
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: nate, Assigned: asa)

Tracking

({verifyme})

Trunk
x86
Linux
verifyme

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.17 i686; en-US; m18) Gecko/20000725
BuildID:

here is what I get when trying to load http://www.mozillazine.org/
(using cvs as of Sept. 18, 9am EDT):
Enabling Quirk StyleSheet
JavaScript strict warning:
http://www.mozillazine.org/ line 47: assignment to undeclared variable ts

JavaScript strict warning:
http://www.mozillazine.org/ line 48: assignment to undeclared variable i

WEBSHELL+ = 5
WEBSHELL+ = 6
./run-mozilla.sh: line 72:  4399 Segmentation fault      $prog ${1+"$@"}


Reproducible: Always
Steps to Reproduce:
1. load http://www.mozillazine.org/

Actual Results:  browser crash
			

Expected Results:  page load							

built on debian potato, gcc version: 2.95.2

Comment 1

18 years ago
WFW Linux 2000-09-18-08 (RH 6.2, kernel 2.2.15, glibc-2.1.3-15)

Comment 2

18 years ago
WFM Linux 2000091908 Debian WOody, marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
verifyme keyword.
Keywords: verifyme
(Reporter)

Comment 4

18 years ago
I am still seeing this crash, but only when javascript is enabled.

I have removed ~/.mozilla, and I removed the dist directory from my cvs
directory.

What else can I try?

Debian Potato
kernel 2.2.17
glibc 2.1.3
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

18 years ago
can i get a better console dump so i can see what js is causing this?  afaik, we
don't use any js on the front page of mz, but it could be the banner ad.

Comment 6

18 years ago
Linux build 092008 with Javascript on still WFM. I'll see if I can grab someone
with Debian Potato to try out a nightly see they see the problem.
(Reporter)

Comment 7

18 years ago
ok:

I downloaded the nightly from today and that WFM.

However, I don't understand why a build I make doesn't work.  Here's the full
text from the console.  This session was started without ~/.mozilla.  After the
default page loads I typed in 'www.mozillazine.org' in the location bar.
(Note that I also had removed my ~/.mozconfig file and deleted config.* from the
cvs directory, then re-built).


Document http://www.mozilla.org/mozorg.html loaded successfully
JavaScript strict warning: 
chrome://navigator/content/navigator.js line 1970: reference to undefined proper
ty window._content.HTTPIndex

WEBSHELL+ = 4
WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 523
JavaScript strict warning: 
chrome://communicator/content/bookmarks/bm-panel.js line 122: function OpenBookm
arkURL does not always return a value

WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 523
JavaScript strict warning: 
chrome://communicator/content/bookmarks/bookmarks.js line 960: redeclaration of 
var cmd

WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 523
JavaScript strict warning: 
chrome://communicator/content/bookmarks/bookmarks.js line 962: redeclaration of 
var cmdResource

WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 523
JavaScript strict warning: 
chrome://communicator/content/bookmarks/bookmarksDD.js line 323: redeclaration o
f var data

WARNING: waaah!, file nsXULPrototypeDocument.cpp, line 523
JavaScript strict warning: 
chrome://communicator/content/bookmarks/bookmarksDD.js line 453: redeclaration o
f var nodeIndex

->>>>>>>>>>>>>> Write Clipboard to memory
JavaScript strict warning: 
 line 9: function onget does not always return a value

JavaScript strict warning: 
 line 9: function onset does not always return a value

Enabling Quirk StyleSheet
JavaScript strict warning: 
http://www.mozillazine.org/ line 47: assignment to undeclared variable ts

JavaScript strict warning: 
http://www.mozillazine.org/ line 48: assignment to undeclared variable i

InstantiateEmbededPlugin for application/x-java-vm
Inside nsPluginHostImpl::FindStoppedPluginForURL...
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
./run-mozilla.sh: line 72: 16073 Segmentation fault      $prog ${1+"$@"}
(Assignee)

Comment 8

18 years ago
hmm, the last thing in the console there is linux legasy plugin support.  maybe
you'll find some insight at http://bugzilla.mozilla.org/show_bug.cgi?id=31012.
I think that mozillazine.org occasionally has htat punch the monkey banner ad
which attempts to load java so maybe it's related since the last output to your
console was about plugin stuff (just a guess) Post to
netscape.public.mozilla.builds if you think its a build problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
tested using linux 2000-09-26-09-MN6 mozilla build. www.mozillazine.org loads
fine now. marking verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.