mousedown event on disabled input do not work

RESOLVED DUPLICATE of bug 218093

Status

()

defect
RESOLVED DUPLICATE of bug 218093
10 years ago
10 years ago

People

(Reporter: bugzilla33, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

497 bytes, text/html
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3


mousedown event on disabled input do not work


Reproducible: Always

Steps to Reproduce:
1. run attachment
Actual Results:  

mousedown event on disabled input do not work


Expected Results:  

mousedown event on disabled input works




<!DOCTYPE html>
<script>
 try{
  document.addEventListener('mousedown',function(e){if(e.target.tagName=='INPUT')alert('OK')},false)
 }catch(e){
  document.attachEvent('onmousedown',function(){if(event.srcElement.tagName=='INPUT')alert('OK')})
 }
</script>
<div><input disabled="" /></div>
<div>Please mousedown input above.<div>
<div style="color:red;padding-top:1em">Firefox 3.6: FAILS</div>
<div style="color:green">Opera: alerts OK</div>
<div style="color:green">IE: alerts OK</div>
Posted file source
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 218093
You need to log in before you can comment on or make changes to this bug.