If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

firefox fails to restore session from previous run

RESOLVED DUPLICATE of bug 531053

Status

()

Firefox
Session Restore
--
critical
RESOLVED DUPLICATE of bug 531053
8 years ago
8 years ago

People

(Reporter: Mikołaj, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b3) Gecko/20091121 Gentoo Firefox/3.6b3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b3) Gecko/20091121 Gentoo Firefox/3.6b3

I've set in preferences to restore last used session, but when running FF it's start with blank page.

Reproducible: Always

Steps to Reproduce:
1. close FF with opened tabs
2. start FF

Actual Results:  
no last tabs have been opened

Expected Results:  
restored tabs from previous session
http://support.mozilla.com/en-US/kb/Preferences+are+not+saved help?
Component: Bookmarks & History → Session Restore
QA Contact: bookmarks → session.restore
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
No help with it. I can change settings and they looks as if they were saved correctly. I should mention before that I've been using this set for years. It's broken since upgrade from FF3.5 to FF 3.6b3.

Maybe it's also connected with https://bugzilla.mozilla.org/show_bug.cgi?id=530335 ?
(Reporter)

Comment 3

8 years ago
After some testing, creating new profiles and so on. I found out that whatever I choose "show my windows and tabs form last time" or "show my home page", FF starts with my home page. When I choose "show blank page", FF shows blank page.
(In reply to comment #2)
> No help with it. I can change settings and they looks as if they were saved
> correctly. I should mention before that I've been using this set for years.
> It's broken since upgrade from FF3.5 to FF 3.6b3.

I know you said this started recently, but is there any chance your preference for clearing data on quit changed as well? If you have Firefox set to "clear history when firefox closes" then this will clear your saved session as well.

> Maybe it's also connected with
> https://bugzilla.mozilla.org/show_bug.cgi?id=530335 ?

Try the things I've suggested there. If you get the same errors/results, then it's likely a dupe

Comment 5

8 years ago
Fixed for me by your patch from #531053. Thanks.
And my Gentoo issue about it https://bugs.gentoo.org/show_bug.cgi?id=295153
Mikołaj, please reopen if this is still a problem with latest nightlies (one from Nov 26 or newer). I'm 99% sure it's the same root problem as bug 531053 (just different symptoms).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 531053
(Reporter)

Comment 7

8 years ago
I'm using gentoo overlay. New version www-client/mozilla-firefox-3.6_beta3-r1 works fine.
You need to log in before you can comment on or make changes to this bug.