Seamonkey 2 crashes with large numbers of tabs opened

RESOLVED INVALID

Status

SeaMonkey
General
--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Oliver Kluge, Unassigned)

Tracking

SeaMonkey 2.0 Branch
x86
OS/2

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1.4) Gecko/20091028 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1.4) Gecko/20091028 SeaMonkey/2.0

In the past days I have seen three different ways how Seamonkey 2 crashes when you open too many tabs. The number varies. Sometimes it's as little as 30, sometimes it is about 90.

a) Access violation (exception C0000005), crash in libc063.dll
b) Abort (SIGABRT) or
c) Segmentation violation (SIGSEGV)

Reproducible: Always

Steps to Reproduce:
1.Go to the URL stated above (www.dreamstime.com), a stock photo agency
2.Search for any keyword
3.Start opening tabs in the background and keep opening
Actual Results:  
After 30 to 80 tabs Seamonkey 2 will crash by one of the 3 ways so far observed.

Expected Results:  
Seamonkey 2 should not crash. If memory becomes a problem (on a 2 GByte machine?), error messages should be displayed, new tabs should be refused.

So far this seams to be an OS/2 only bug, I could not reproduce it on Windows. The machine here is an AMD 64 with 2 GBytes of RAM.

Information I could gather:

11-07-2009  01:56:14  SYS3175  PID 0082  TID 0001  Slot 0092
D:\BIN\SEAMONKEY2\SEAMONKEY.EXE
c0000005
1db8ac7f
P1=00000001  P2=268f4000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=268f3a78  ECX=268f3a80  EDX=00000000
ESI=268f39f0  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0053  GSACC=f0f3  GSLIM=ffffffff
CS:EIP=e01f:000028a1  CSACC=00df  CSLIM=0000de13
SS:ESP=0053:268f39de  SSACC=f0f3  SSLIM=ffffffff
EBP=268f3a04  FLG=00212206

LIBC063.DLL 0001:0000ac7f

/--/

Killed by SIGABRT
pid=0x0052 ppid=0x0021 tid=0x0001 slot=0x0095 pri=0x0200 mc=0x0001
D:\BIN\SEAMONKEY2\SEAMONKEY.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

/--/

Killed by SIGSEGV
pid=0x0055 ppid=0x0021 tid=0x0001 slot=0x008d pri=0x0200 mc=0x0001
D:\BIN\SEAMONKEY2\SEAMONKEY.EXE
XPCONNECT 0:00003c95
cs:eip=005b:1d5b3c95 ss:esp=0053:0011eed4 ebp=0011ef1c
ds=0053 es=0053 fs=150b gs=0000 efl=0052202
eax=73fa1000 ebx=5d67d580 ecx=201514e0 edx=2003a994 edi=202d2840 esi=0011eef0
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

Large numbers of tabs appears to have be a problem with Seamonkey on OS/2 for a longer time. On the 1.x branch I occasionally witnessed that after opening many tabs the latest would be broken: content missing, scrollbars dead, parts of tabs remaining on screen after switching away from them, etc. Once that point was reached, all newly opened or refreshrd tabs would be broken. Tabs that were loaded correctly would remain okay. Closing broken tabs would not cure the problem. Continued use of a Seamonkey instance with broken tabs would eventually lead to a hang, in severe cases taking the operating system with it. But I have never seen Seamonkey crash on too many tabs, that's new with SM 2.
(Reporter)

Updated

9 years ago
Version: unspecified → SeaMonkey 2.0 Branch

Comment 1

9 years ago
Likely libc problem
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
I seriously doubt that.

a) Here no other program has ever had problems resulting in segmentation violations, access violations or the like using this libc063. That includes Seamonkeys previous builds. Seamonkey 2 is the first program ever to crash several times a day, sometimes with just minutes between crashes.

b) A couple of the SIGSEGV is in XPCONNECT, and not in libc.
You need to log in before you can comment on or make changes to this bug.