Not displayed input field can not have a value be set on a click event

RESOLVED FIXED

Status

()

Core
DOM: Events
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Alexandre Trepp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3

This bug does not happen with 3.5 only with the 3.6beta1/2/3

Reproducible: Always

Steps to Reproduce:
1. open this page http://www.almandra.com/test.html
2. click process
Actual Results:  
input field has an empty value

Expected Results:  
input field should have the value "test passed"

<!-- source code -->
<script>
function process() {
	document.getElementById('container').style.display = 'none';
	document.getElementById('field').value = 'test passed';
	document.getElementById('container').style.display = 'block';
}
</script>

<div id="container">
	<input id="field" type="text" name="field"/>
</div>

<a href="#" onclick="javascript:process()">Process</a>

Comment 1

8 years ago
Works on trunk/OSX

Comment 2

8 years ago
But doesn't work on 3.6/OSX
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

8 years ago
I need the test still the very latest 3.6 build
WFM on Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091122 Minefield/3.7a1pre

Comment 5

8 years ago
Alexandre, could you retry with very latest 3.6 build, because the testcase
works here using that.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.2/
(Reporter)

Comment 6

8 years ago
I just downloaded the latest build ( Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2b4pre) Gecko/20091122 Namoroka/3.6b4pre )
and it works with this build, thanks :)
have a nice day,
alex
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.