Lines in html which starts with <!-- and end with --> doesn't work correctly

RESOLVED DUPLICATE of bug 214476

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 214476
9 years ago
9 years ago

People

(Reporter: middle_of_nowere, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Some websites use lines like 
<!--------------------------------------------------------------------------------------->
to indicate inside the html-code a new section is started.
<!-- is to indicate that a comment begins and the --> is to indicate that the commend ends.
Firefox doesn't display the rest of the website.

Reproducible: Always

Steps to Reproduce:
Use the following html-code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">
<head>
  <title>Test</title>
</head>
<body>
	Line1<br />
	<!--------------------------------------------------------------------------------------->     
	Line2<br />
	<!--------------------------------------------------------------------------------------->     
	Line3<br />	
</body>
</html>
Actual Results:  
Website shows:
Line1
Line3

Expected Results:  
Website should show like:
Line1
Line2
Line3

When I press Ctrl+A, the text "Line2" is also copied. It looks that the text is invisible.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 214476
Make sure your hyphens come in multiples of four
http://htmlhelp.com/reference/wilbur/misc/comment.html
You need to log in before you can comment on or make changes to this bug.