TB freezes up when moving messages between IMAP folders

RESOLVED DUPLICATE of bug 296453

Status

--
critical
RESOLVED DUPLICATE of bug 296453
9 years ago
8 years ago

People

(Reporter: thomas, Unassigned)

Tracking

({hang})

Trunk
Thunderbird 3.1b1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0

Build 3 of the RC1 candidates has a bad habit of locking up the entire UI when you move 10-50k messages between IMAP folders.  During that freezes, the entire application window becomes unresponsive, including sub-windows like the Error Log or Activity Manager.  CPU usage pegs at 100% of a CPU core.

Reproducible: Always

Steps to Reproduce:
1. Take a folder with 5k to 50k messages
2. Select all messages
3. Right-click, move to another folder in the same mailbox


Actual Results:  
Entire TB UI will freeze and become unresponsive until move finishes.  No status updates are given to the user as to how the move is progressing.  Depending on how many messages were moved it can be anywhere from 10 seconds to a few minutes until TB returns control to the end-user.  Immediately after the move, the TB UI will refresh before locking up again while it does something else (indexing? updating the MSF?).  This second freeze can be as long or longer then the first freeze.

Expected Results:  
TB UI should be doing the move in the background while remaining responsive to the end-user.

I'm filing this bug against TB v3 RC1 build 3 because it seems to have only become really noticeable during the RC builds and not during previous betas.  This freeze also occurs at two different points, during the initial move and then again after the move completes.

This freeze does not happen when moving messages between local folders.  There, the move takes place in the background (although the UI gets a bit sluggish) with updates being reported in the status bar.
(Reporter)

Comment 1

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091117 Thunderbird/3.0
- Also present in build 2 of RC1, same symptoms

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091112 Thunderbird/3.0
- Also present in build 1 of RC1, same symptoms

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4
- Also present in 3.0 beta 4, same symptoms 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.1) Gecko/20090715 Thunderbird/3.0b3
- Also present in 3.0 beta 3, same symptoms 

Seems to be a pretty old bug, although I can't find anything similar in the bug reports.

Updated

9 years ago
Whiteboard: dupeme
(Reporter)

Comment 2

9 years ago
The interesting thing is that if you use the search window and the "File" button at the bottom of that window, it takes care of the move without locking up the entire TB UI.

Two different code paths for accomplishing the same thing?
Summary: TB 3.0RC1 build 3 UI freezes up when moving messages between IMAP folders → TB freezes up when moving messages between IMAP folders
Could be a dupe of bug #296453
Severity: normal → critical
Keywords: hang
(In reply to comment #0)
> locking up again while it does something else (indexing? updating the MSF?).
> This second freeze can be as long or longer then the first freeze.

Phenomenon of Bug 452221?
(Bug 452221 is a spin-off of specific problem/phenomenon in Bug 296453)
If yes, test with mails of no deep/long threads, please, in order to rule out problem of Bug 452221.

Comment 5

8 years ago
When bug 296453 gets fixed, if Thomas doesn't see the problem go away then this bug can be reopened. for now, dup of bug 296453
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → Thunderbird 3.1b1
Version: unspecified → Trunk
Duplicate of bug: 296453
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.