Brkwser crashes after pressing OK on 'No Plugin Downloader Plugin'

VERIFIED FIXED

Status

()

P2
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: shrir, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nsbeta3+ [PDTP2], URL)

(Reporter)

Description

18 years ago
Build:2000091508m18 , linux

Pls reassign if this belongs to OJI.

Steps:

1 Go to the above url
2 The webpage contains an embedded applet
3 A ' No Plugin Downloader Plugin' dialog pops up as a result of the default 
  plugin not being under linux (another bug)
4 Pressing OK on this dialog crashes the browser

Expected: Pressing OK should just dismiss the dialog and display the webpage and 
not crash the browser.

Stack Trace:


 Call Stack:    (Signature = SinkContext::FlushTags() a7f9de69) 
     
   SinkContext::FlushTags() 
                                               
     
   HTMLContentSink::BeginContext() 
                                               
     
   CNavDTD::HandleSavedTokens() 
                                               
     
   CNavDTD::HandleOmittedTag() 
                                               
     
   CNavDTD::HandleDefaultStartToken() 
                                               
     
   CNavDTD::HandleStartToken() 
                                               
     
   CNavDTD::HandleToken() 
                                               
     
   CNavDTD::BuildModel() 
                                               
     
   nsParser::BuildModel() 
                                               
     
   nsParser::ResumeParse() 
                                               
     
   nsParser::OnDataAvailable() 
                                               
     
   nsDocumentOpenInfo::OnDataAvailable() 
                                               
     
   nsHTTPFinalListener::OnDataAvailable() 
                                               
     
   InterceptStreamListener::OnDataAvailable() 
                                               
     
   nsHTTPServerListener::OnDataAvailable() 
                                               
     
   nsOnDataAvailableEvent::HandleEvent() 
                                               
     
   nsStreamListenerEvent::HandlePLEvent() 
                                               
     
   PL_HandleEvent() 
                                               
     
   PL_ProcessPendingEvents() 
                                               
     
   nsEventQueueImpl::ProcessPendingEvents() 
                                               
     
   event_processor_callback() 
                                               
     
   our_gdk_io_invoke() 
                                               
     
   libglib-1.2.so.0 + 0xe52a (0x4088e52a) 
                                               
     
   libglib-1.2.so.0 + 0xfbe6 (0x4088fbe6) 
                                               
     
   libglib-1.2.so.0 + 0x101a1 (0x408901a1) 
                                               
     
   libglib-1.2.so.0 + 0x10341 (0x40890341) 
                                               
     
   libgtk-1.2.so.0 + 0x8c209 (0x407ba209) 
                                               
     
   nsAppShell::Run() 
                                               
     
   nsAppShellService::Run() 
                                               
     
   main1() 
                                               
     
   main() 
                                               
     
   libc.so.6 + 0x181eb (0x402541eb)

Comment 1

18 years ago
Nominating for nsbeta3
Keywords: nsbeta3

Comment 2

18 years ago
Reassigning to Marc.
Assignee: av → attinasi

Comment 3

18 years ago
Marking nsbeta3+ P1.
Priority: P3 → P1
Whiteboard: nsbeta3+
(Reporter)

Comment 4

18 years ago
*** Bug 53386 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

18 years ago
Accepting: I've seen this now too, and I'm debugging it.
Status: NEW → ASSIGNED
(Assignee)

Comment 6

18 years ago
This seems to happen on NT as well if I rename or delete the Plugins folder. The
crash is slightly different, and sometimes I have to reload the document before
it crashes, but I bet they are related if not the same prolem.

I also see a tiny pop-up window on NT with a garbage title, and that seems
suspicious too. Still investigating...

Comment 7

18 years ago
I see that garbage pop up window too, but when I try to do xpinstall.

Comment 8

18 years ago
Not a ship stopper, nasty but relatively infrequent.
Priority: P1 → P2
Whiteboard: nsbeta3+ → nsbeta3+ [PDTP2]

Comment 9

18 years ago
That mysterious pop-up window is bug 51619 which has just been fixed.
(Assignee)

Comment 10

18 years ago
Since the mysterious popup window (bug 51619) has been fixed this no longer
crashes on NT. I'm waiting for my Linux build to finish to see if that platform
is affected, but according to the notes in bug 51619, I should not and will not
hold my breath.
(Assignee)

Comment 11

18 years ago
This has been fixed (presumably by the fix to bug 51619). No more crash after
dismissing the 'no plugin downloader plugin' dialog.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
I verified this on linux br build 2000092909.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.