Closed Bug 530505 Opened 11 years ago Closed 11 years ago

Changed interfaces without changing iid

Categories

(Core :: XUL, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1

People

(Reporter: pjemen, Assigned: pjemen)

Details

Attachments

(7 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729) XPCOMViewer/0.9a
Build Identifier: 

I compared interfaces of gecko 1.8.1 and 1.9.2
There are interface changes there are hidden by inheritance.
This issues occurs when you change parent interface and don't change iid of derived interface. 

Here are affected interfaces with description:

nsIDOMXULControlElement needs new iid due to changes in parent interface nsIDOMXULElement
 nsIDOMXULTextBoxElement needs new iid due to changes in parent interface nsIDOMXULElement
  nsIDOMXULMenuListElement needs new iid due to changes in parent interface nsIDOMXULElement
  nsIDOMXULMultiSelectControlElement needs new iid due to changes in parent interface nsIDOMXULElement
 nsIDOMXULLabeledControlElement needs new iid due to changes in parent interface nsIDOMXULElement
  nsIDOMXULCheckboxElement needs new iid due to changes in parent interface nsIDOMXULElement
  nsIDOMXULButtonElement needs new iid due to changes in parent interface nsIDOMXULElement
nsIDOMXULTreeElement needs new iid due to changes in parent interface nsIDOMXULElement
nsIDOMXULSelectControlItemElement needs new iid due to changes in parent interface nsIDOMXULElement
nsIDOMXULPopupElement needs new iid due to changes in parent interface nsIDOMXULElement
nsIDOMXULDescriptionElement needs new iid due to changes in parent interface nsIDOMXULElement
 nsIDOMXULLabelElement needs new iid due to changes in parent interface nsIDOMXULElement
nsIDOMXULImageElement needs new iid due to changes in parent interface nsIDOMXULElement
nsIDOMXULMenuListElement needs new iid due to changes in parent interface nsIDOMXULSelectControlElement
nsIDOMXULMultiSelectControlElement needs new iid due to changes in parent interface nsIDOMXULSelectControlElement
nsIExtendedExpatSink needs new iid due to changes in parent interface nsIExpatSink
nsINativeTreeView needs new iid due to changes in parent interface nsITreeView 
nsIASN1Tree needs new iid due to changes in parent interface nsITreeView
nsIAuthPromptWrapper needs new iid due to changes in parent interface nsIAuthPrompt
nsIToolkitChromeRegistry needs new iid due to changes in parent interface nsIXULChromeRegistry
nsITransfer needs new iid due to changes in parent interface nsIWebProgressListener2
nsPIDNSService needs new iid due to changes in parent interface nsIDNSService
 nsIToolkitChromeRegistry needs new iid due to changes in parent interface nsIChromeRegistry
nsIAutoCompleteBaseResult needs new iid due to changes in parent interface nsIAutoCompleteResult
 nsIAutoCompleteMdbResult needs new iid due to changes in parent interface nsIAutoCompleteResult
  nsIAutoCompleteMdbResult2 needs new iid due to changes in parent interface nsIAutoCompleteResult

Their iid's should be changed at least in 1.9.3.

Reproducible: Always
Attachment #416544 - Attachment is patch: true
Attachment #416544 - Attachment mime type: application/octet-stream → text/plain
Attachment #416544 - Flags: review?(bzbarsky)
Attachment #416544 - Attachment description: Proposed patch for xul → Proposed patch for xul in Gecko 1.9.3
Comment on attachment 416544 [details] [diff] [review]
Proposed patch for xul in Gecko 1.9.3 [checkin: comment 3]

Probably better for one of the xul owners to review this....
Attachment #416544 - Flags: review?(bzbarsky) → review?(neil)
Attachment #416544 - Flags: review?(neil) → review+
Keywords: checkin-needed
Pushed to m-c: http://hg.mozilla.org/mozilla-central/rev/8cd4df9db5a0
Assignee: nobody → pjemen
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Component: General → XUL
Flags: in-testsuite-
Keywords: checkin-needed
QA Contact: general → xptoolkit.widgets
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Attachment #419884 - Flags: review?(mrbkap)
reopen
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Attachment #419884 - Attachment description: Proposed patch for parser → Proposed patch for parser in gecko 1.9.3
Attachment #419911 - Flags: review?(neil)
Attachment #419912 - Flags: review?(kaie)
Attachment #419913 - Flags: review?(benjamin)
Attachment #419914 - Flags: review?(benjamin)
Attachment #419915 - Flags: review?(benjamin)
Attachment #419916 - Flags: review?(cbiesinger)
Attachment #419911 - Flags: review?(neil) → review+
Probably should have opened new bugs, but I'll just mark the patch I checked in as checked in...
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #416544 - Attachment description: Proposed patch for xul in Gecko 1.9.3 → Proposed patch for xul in Gecko 1.9.3 [checkin: comment 3]
Comment on attachment 419916 [details] [diff] [review]
Proposed patch for nsPIDNSService in gecko 1.9.3

As far as I can tell, only constants were added to nsIDNSService, right? So it should never have gotten a new IID, and this interface doesn't need a new IID either.
Comment on attachment 419916 [details] [diff] [review]
Proposed patch for nsPIDNSService in gecko 1.9.3

(In reply to comment #13)
> (From update of attachment 419916 [details] [diff] [review])
> As far as I can tell, only constants were added to nsIDNSService, right?

Yes, you are right.
Tool I used was checking iid of parent interface. Because iid was changed when new constants were added to nsIDNSService it thought that parent interface was changed. So this is false positive. Sorry.
Attachment #419916 - Attachment is obsolete: true
Attachment #419916 - Flags: review?(cbiesinger)
Attachment #419884 - Flags: review?(mrbkap) → review+
Attachment #419912 - Flags: review?(kaie) → review+
Attachment #419913 - Flags: review?(benjamin) → review+
Attachment #419914 - Flags: review?(benjamin) → review+
Attachment #419915 - Flags: review?(benjamin) → review+
Keywords: checkin-needed
Pushed http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=c9d37da89ae4
Status: ASSIGNED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.