If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Error uploading -> two files added, one empty

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Developer Pages
P3
minor
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Dave Garrett, Unassigned)

Tracking

unspecified
4.x (triaged)
x86
Linux

Details

(Reporter)

Description

8 years ago
Tried to upload version 1.2pre for Crash Report Helper (11217) and got:

Oops! There seems to be a problem with this file...
An error occurred moving crashreporthelper1.2pre1.xpi.
Please correct this problem and upload your file again.

I checked the versions list anyway, and it was there... twice. The top one had no file and suggested removal, which I did. The bottom one seems fine, which I completed.

Didn't try to reproduce; filing because it shouldn't do that. ;)
(Reporter)

Comment 1

8 years ago
This is quite repeatable. The exact same thing happened when I uploaded 1.2.
I tried to reproduce this on preview, but wasn't able to. Same add-on and same file, but it uploaded fine. This is either (1) fixed on preview, or (2) dependent on the user's system. Maybe a network connection problem?
Severity: normal → minor
Priority: -- → P3
Target Milestone: --- → 4.x (triaged)
(Reporter)

Comment 3

8 years ago
I just deleted your attempt on preview and tried there myself. No problems. #1 looks like a possibility, but I don't know.
(Reporter)

Comment 4

8 years ago
I just got this on production again, this time on uploading Flagfox 3.3.19:

Oops! There seems to be a problem with this file...
An error occurred moving 77726900 1260244201.xpi.
Please correct this problem and upload your file again.

Again, two files listed in the versions list with the top one empty. This time, however, it oddly botched the filename in its error message. It was "flagfox3.3.19.xpi" on upload.

If this is fixed on preview, then I guess I'll find out when I make it to the next Flagfox monthly update after a push.
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> If this is fixed on preview, then I guess I'll find out when I make it to the
> next Flagfox monthly update after a push.

This month the process went flawlessly. Closing as WFM.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.