Can not remove a feed using 'Manage subscriptions'

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: vkondakoff, Unassigned)

Tracking

Trunk
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround comment #2])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091122 Shredder/3.0.1pre

I was trying to change (edit) the feed URL, but the developers said they intentionally not allow to edit the feeds URL (https://bugzilla.mozilla.org/show_bug.cgi?id=530500). Then I tried to delete the old feed first and add the new feed later, but when I go to Manage subscription, select the specific feed and press 'Remove' I receive the following error:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80550006 [nsIMsgFolder.msgDatabase]"  nsresult: "0x80550006 (<unknown>)"  location: "JS frame :: chrome://messenger-newsblog/content/utils.js :: updateFolderFeedUrl :: line 155"  data: no]

And the feed is question is not removed.

Reproducible: Always
WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091121 Lightning/1.0pre Thunderbird/3.0 ID:20091121183158

Valery it happeans also in safe-mode?
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
Hmmm... Right now I can not reproduce this issue, just because I deleted the two 'non-deleteable' RSS-folders manually and now all other folders are deleted without problem in both normal and save modes.

I'll try to investigate this issue further.
Ok Valery thanks for feedback: I close as WFM.

Feel free to reopen it if the issue resurrect.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: [workaround comment #2]
You need to log in before you can comment on or make changes to this bug.