Request: Have the close button directly on the tab

RESOLVED DUPLICATE of bug 117077

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 117077
8 years ago
8 years ago

People

(Reporter: olivier sannier, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

Hello all,

I'm currently evaluating SM2 and I'm wondering if I could get back the functionality I had with an extension I used in SM1. Basically, it allowed to have many more options for tabbed browsing, and while most of them are in SM2, I dearly miss the "Close button on tab" feature.
Basically, when hovering on top of the tab icon, it would change to the close button icon and clicking on it would close the tab, whether it was the active one or not.
I tried looking in the options for such a setting but could not find anything.
Note that I know about Middle Click, but it does not feel as natural as clicking on a button.

Reproducible: Always

Steps to Reproduce:
Click on the tab to close it, nothing happens.
(Reporter)

Comment 1

8 years ago
I just discovered the "browser.tabs.closeButtons" option as described here:
http://kb.mozillazine.org/Browser.tabs.closeButtons

But changing its value to any value between 0 and 3 does not change anything.
So maybe this issue should be adjusted to say that SM2 does not respect this value.

Comment 2

8 years ago
Is it duplicate bug 117077 ?
(Reporter)

Comment 3

8 years ago
I think it should be the other way round, because when you read the comments for but 117077, it says it is fixed in Firefox and that another bug should be opened for SeaMonkey
(Reporter)

Comment 4

8 years ago
Further to this, I noticed a weird behavior with the browser.tabs.closeButtons property.
It is ignored by the browser, but it is perfectly taken into account in the mail client.

Comment 5

8 years ago
Bug 117077 is for Seamonkey.
Severity: enhancement → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 117077
You need to log in before you can comment on or make changes to this bug.