@font-face and forced bold

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: ric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3

Hello,

This is a subjective rendering issue really, but sometimes fonts embedded with @font-face can render poorly when they are using 'forced bold'. i.e. fatten up rendered as a bold face when really they are regular. FF 3.5 didn't force bold faces (I think), but 3.6 seems to. I don't know if it's better not to do anything, or if force bolding text is best. It would be nice if web developers could see if a font is being made bold automatically so we could then decide what to do.

Reproducible: Always

Steps to Reproduce:
1. Add am @font-face font to page
2. Set it to be bold font-weight:bold;
Actual Results:  
Font it rendered too bold.

Updated

9 years ago
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Presumably we're doing synthetic bolding because the bold face in the family wasn't provided.  If you want to use font-weight:bold and @font-face, you should provide both fonts in @font-face rules (and likewise for italics), e.g.,:

@font-face {
    font-family: "Gentium Basic";
    src: url("GenBasB.ttf");
    font-weight: bold;
    font-style: normal; /* default, can be omitted */
}

@font-face {
    font-family: "Gentium Basic";
    src: url("GenBasR.ttf");
    font-weight: normal; /* default, can be omitted */
    font-style: normal; /* default, can be omitted */
}

@font-face {
    font-family: "Gentium Basic";
    src: url("GenBasI.ttf");
    font-weight: normal; /* default, can be omitted */
    font-style: italic;
}

@font-face {
    font-family: "Gentium Basic";
    src: url("GenBasBI.ttf");
    font-weight: bold;
    font-style: italic;
}

Comment 2

9 years ago
Yes, synthetic bolding on Windows was fixed for 3.6.  As David notes, authors have complete control over this by simply defining a bold face or not using bolded elements.  Not sure there's a bug here.
(Reporter)

Comment 3

9 years ago
Hello,

Okay, that's all clear now. I wasn't sure how it was set so when I tested some code using H1.6 tags they rendered differently. But Now I know I agree that the 3.6 implementation is the best.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

7 years ago
Duplicate of this bug: 675656
You need to log in before you can comment on or make changes to this bug.