Open Bug 530608 Opened 10 years ago Updated 1 year ago

If a modal dialog box is open, a triggered message in the background makes the box inoperable

Categories

(Thunderbird :: Mail Window Front End, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

REOPENED

People

(Reporter: Nomis101, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: ue, Whiteboard: dupeme)

Attachments

(2 files)

Today I had an annoying experience with Thunderbird. I started TB to compose a new mail. In the background Thunderbird was searching for new mails. Because this takes so long I opened a compose window and started to write my mail. At the moment I was trying to add an attachment to my mail a message popped up in the background to inform me about a timeout for my connection. But I was not able to click "OK" because I can't get the attachment window to close. Clicking Cancel ("Abbrechen") had no affect.



Steps to reproduce:
1. Start Thunderbird
2. While TB is searching for new messages open a compose window
3. Open the attachment window to add attachments to your mail
4. Let the connection time out (don't know how you can force this)
--> Now TB is out of control because none of the buttons work.


Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.1.5) Gecko/20091123 Shredder/3.0.1pre


Note: I'm using POP3
Whiteboard: dupeme
The specific alert you're on about is already covered by bug 123440.

The general issues and more can be found https://wiki.mozilla.org/Thunderbird:Dialog_Invasion
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
Status: RESOLVED → VERIFIED
123440 is not really a duplicate of my bug. My problem is of a more general kind. It's not only the timeout window. ANY dialog box in the background makes Thunderbird inoperable if a modal dialog is open at this time. Bug 123440 will only fix the problem for the timeout message.
My new attachment shows another example. If you have the attachment chooser open and you get a message from the ISP "web.de" than Thunderbird also gets inoperable. You can't click "Cancel", you can't click "OK" and you can't quit the application. You have to force quit it.
This are only two examples, there are maybe more...
this is effectively bug 476541
Status: VERIFIED → REOPENED
Depends on: 476541
Resolution: DUPLICATE → ---
Duplicate of this bug: 647408
Duplicate of this bug: 838213
Duplicate of this bug: 847179
Duplicate of this bug: 1113169
Do you still see this problem when using version 45?
Flags: needinfo?(gasser)
Flags: needinfo?(Nomis101)
I am not sure, step 4 (connection time out) is tricky to reproduce.
Flags: needinfo?(Nomis101)
Ditto - haven't checked, but neither has it just showed up. Is there some reason to expect it has been fixed? I.e. is there evidence that someone has actually worked on it? - Les
(In reply to Les Gasser from comment #10)
> Is there some reason to expect it has been fixed? 

Yes. I am asking because the blocking bug 476541 has been closed. I don't have ability to test Mac
Flags: needinfo?(gasser)

(In reply to Wayne Mery (:wsmwk) from comment #3)

this is effectively bug 476541

Sadly has made no progress

Severity: major → critical
You need to log in before you can comment on or make changes to this bug.