Clicking on the last few links including the Last>> link does not load the appropriate page in the search results

VERIFIED FIXED in 1.5

Status

support.mozilla.org
General
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: krupa, Assigned: paulc)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only, URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
steps to reproduce:
1.Search for "firefox browser"
2.Notice that there are 106 pagination links
3.Click on the Last>> link

expected behavior:
the 106 page loads

observed behavior:

The 101 page loads.Clicking directly on 106 link does not load the 106th page.These links look like dummy links.

screencast:http://screencast.com/t/OTE5NDY5MT
(Assignee)

Updated

8 years ago
Assignee: nobody → paulc
(Assignee)

Comment 1

8 years ago
Created attachment 414137 [details] [diff] [review]
v1

There we go. This should also fix the other two bugs that relate to offsets (invalid formatting and URL parameters) (bug 530262 and bug 530261, possibly bug 530677). I tested this out with allowed where values (all, d, f).
Attachment #414137 - Flags: review?(james)
Is the intention of this patch to limit results to 1000?
(Assignee)

Comment 3

8 years ago
It's to fix the way results are formatted and removing the limit on the actual offset -- since we search kb + forum and each has a max of 1000, total may be over 1000. We can go the other way and make it be at most 1000 added up, if that's what you want.
Comment on attachment 414137 [details] [diff] [review]
v1

/me is an idiot. It's limited to 1000 with where=f. Works for me.
Attachment #414137 - Flags: review?(james) → review+
(Assignee)

Comment 5

8 years ago
Thanks James!
r56725
*fingers crossed* Hope this fixes those other two mentioned in comment 1.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

8 years ago
verified this bug.The bugs mentioned in comment 1 have not been verified
Status: RESOLVED → VERIFIED
(In reply to comment #6)
> verified this bug.The bugs mentioned in comment 1 have not been verified

They have, actually :-)
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.