Double clicking individual tabs on about:sessionrestore should reopen that tab

RESOLVED DUPLICATE of bug 563291

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 563291
9 years ago
9 years ago

People

(Reporter: scott, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5

I observed my girlfriend use the "whoops this is embarrassing" page for the first time.  She wanted her tabs back, but was confused by the wording of the page.

First she tried to double click the specific tab she wanted, presumably expecting it to open in a new tab.  That didn't work.

Then she clicked "start new session" instead of "restore", which is exactly what she didn't want to do.  I believe the problem is that "start new session" is too close in meaning to what she was doing, namely restarting her time with Firefox.  Here, the normal and technical meaning of session differ.  Moreover, there's nothing in the wording of "new session" that suggests the discarding about to occur.


Instead, I recommend changing the "Start new session" button to something closer to what it really does - forget the old tabs and open the home page.

As a first suggestion, I propose "Open my homepage".  The restore option could be "Open the above tabs".  It would also help if neither button looked like the default, as the user has to make a real decision here.

Reproducible: Always

Steps to Reproduce:
1.Crash
2.???
3.See embarrassing page
So you're suggesting 3 things here, two of which I think match up with bugs we have already.

For styling/layout of the buttons, we have bug 477322. There is also some talk about the strings used in the bug, but I think bug 523140 was opened with the intention of handling that. Feel free to CC yourself and comment on those bugs.

For making the tabs clickable, that's something different. Right I'm pretty sure they are middle-clickable (which is the default mouse click for opening in a new tab), which should work.

Double clicking is something else. Since your other two suggestions are covered, I'm going to make your bug about that.
Severity: normal → enhancement
OS: Linux → All
Hardware: x86 → All
Summary: Make individual tabs on embarrassing page clickable and rename "Start new session" → Double clicking individual tabs on about:sessionrestore should reopen that tab
Version: unspecified → Trunk
I'm going to take the part of this bug where you suggest double clicking. That got fixed in another bug.

As for the "start new session" suggestion, we're actually getting rid of that button entirely in bug 477322.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 563291
You need to log in before you can comment on or make changes to this bug.