Prevent updater from running when multiple instances of Firefox are open

RESOLVED DUPLICATE of bug 344525

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 344525
8 years ago
8 years ago

People

(Reporter: rc, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Steps to reproduce:
1. Launch Firefox with your default profile
2. Launch another instance of the same Firefox application via the command line, (on a mac, e.g., /Applications/Firefox/Contents/MacOS/firefox-bin -P)
3. Select or create another profile from step 2.
4. Install an add-on into the second profile
5. Click Restart

Somewhere between steps 2 and 5, one of these profiles has to download an update. This is made easier when using nightlies and you've left both your profiles running overnight.

When activating Restart in step 5, the second Firefox will begin running the updater. The original version of Firefox continues running, though its binaries may have been pulled out from under it. This Can Be Bad.

I run into this daily with my development and daily-use profiles. I should probably switch one to a different application version. Nevertheless, there are good reasons for running multiple instances of the same version of Firefox.
Sorry for not being clearer in the beginning of my status report... the bug I fixed for this was Windows specific (bug 312010) and there are already bugs filed a while ago for this by bsmedberg for Mac OS X (bug 344525) and Linux (344526) which will both need a different approach.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 344525
You need to log in before you can comment on or make changes to this bug.