Closed Bug 530865 Opened 13 years ago Closed 13 years ago

Autocomplete disregards Nickname field in address book

Categories

(SeaMonkey :: MailNews: Composition, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 325458

People

(Reporter: irzonca, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091017 SeaMonkey/2.0

When addressing an email the autocomplete feature does not give priority to the "Nickname" field from the Address Book.


Reproducible: Always

Steps to Reproduce:
1. Create a contact with Nickname: x Email: x@example.com
2. Create a contact with Email: X@example.net
3. Compose a new email message.
4. Enter a lower-case 'x' in the "To:" field.
Actual Results:  
Autocomplete will suggest the contact with no Nickname configured.

Expected Results:  
Autocomplete should give a higher priority to any contact with a Nickname field that is an exact match for the input.

Verified on a fresh SeaMonkey profile.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 13 years ago
Component: Autocomplete → MailNews: Composition
QA Contact: autocomplete → mailnews-composition
Resolution: --- → DUPLICATE
Duplicate of bug: 325458
You need to log in before you can comment on or make changes to this bug.