Thunderbird closes when closing child window

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: tech, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091106 Shiretoko/3.5.5
Build Identifier: version 2.0.0.23 (20091001)

When I perform a search and then select to open one of the items found, I get a new window.  The original Thunderbird window is still open.  When I close the child window, the whole program closes and there are no windows left open.

Reproducible: Always

Steps to Reproduce:
1.Edit, Find, Search Messages
2.Inbox on Local Folders, Search sub-folders, Body contains, Search
3.Select one of the results, Open
4.Child window opens, it looks like the main window but with one piece of mail filling the window under the menu and button bars.
5.Select the top right X to close.  Both windows close, followed by search box.
Actual Results:  
Program crashes or closes.

Expected Results:  
Search box and main window should have remained open.

Addons:
Aboutconfig 0.6, Check and Send 0.8.30, Confirm-Address 1.2.2, Folderpane Tools 0.0.5.1, Mail Tweak 0.16, MR Tech Toolkit 6.0.3.4, Remember Mismatched Domains 1.4.6, Restart Thunderbird 0.9.1, Spamato4Thunderbird 0.99.1.3, Xpunge 0.3
Theme:
Tango Icons for Thunderbird 0.7.0

Arch Linux, Xfce 4.6.1
Component: General → Mail Window Front End
QA Contact: general → front-end
Version: unspecified → 2.0
can you reproduce in safe mode?
 https://support.mozilla.com/en-US/kb/Safe+Mode
if not, then the issue may be an extension.
if you can, does it also fail in version 3?
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 (almost released .... backup your profile first)
Severity: major → critical
(Reporter)

Comment 2

9 years ago
Changed to version 3.0.  Selected search result opens in tab.  Closing tab has no affect on program.  Tabs work correctly, where separate window did not.

Sorry I wasn't able to try your request in 2.x.  I didn't receive any email notification.  At least it is no longer an issue in 3.0.  However, there are some serious problems in 3.0 which may force a downgrade.  I'll let you know if I do.
WFM per reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.