New crash [@ NewGCThing<JSString>][@ NewGCThing<JSObject>][@ NewGCThing<JSFunction>] in Firefox 3.6b3

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: jst, Unassigned)

Tracking

({regression})

1.9.2 Branch
regression
Points:
---
Bug Flags:
blocking1.9.2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [crashkill][not new?], URL)

Attachments

(1 attachment)

Blocking -- looks like an ugly crash.
Flags: blocking1.9.2? → blocking1.9.2+

Comment 2

9 years ago
Could we get some url data for these crashes? Stacks don't look to useful.
Keywords: qawanted

Comment 3

9 years ago
Created attachment 414780 [details]
santized url list 'NewGCThing<JSString>' 200911*

url list doesn't look to helpful either.  a lot where apps behind some auth/login

google, yahoo, live mail
google docs
orkut  facebook 
facebook apps

google, youtube, other video

and a bunch of other random stuff mixed in.

might correlate pretty well with general browsing.
I've been looking at a minidump for one of the NewGCThing<JSString> crashes. The line number reported by the web interface seems to be wrong: in this minidump, the crash is actually caused by the store for '*flagp = (uint8) flags' near the end of the function. In this minidump, flagp = 0xb, so that's not going to work.

I was also able to tell that gcLocked = 0, so we must have taken the early success 'exit' (goto success) near line 1808, which probably explains the fake line number.
AFAICT, this crash is not at all new; there are examples from FF3.0 that seem to be the same crash, e.g.:

http://crash-stats.mozilla.com/report/index/f0b0c550-f9c6-4208-b7ba-940332091130

We might want to remove blocking status.
Moving this back to a nom based on Comment 5.  If this is indeed a blocker, let's get an owner ASAP.
Flags: blocking1.9.2+ → blocking1.9.2?
One of the Win Vista crash comments mentions the Mozmill IDE - I installed the extension but was not able to crash. Adding Henrik to the bug as we may have more insight here since he uses Mozmill regularly.
Whiteboard: [crashkill][not new?]
(In reply to comment #7)
> One of the Win Vista crash comments mentions the Mozmill IDE - I installed the
> extension but was not able to crash. Adding Henrik to the bug as we may have
> more insight here since he uses Mozmill regularly.

Marcia, can you please point me to this report? I'm not able find it for any of the specified signatures.

Comment 9

9 years ago
20091201-crashdata.csv:

nsCOMPtr_base::assign_from_qi(nsQueryInterface, nsID const&) | nsCOMPtr<nsICSSStyleRule>::operator=(nsQueryInterface) | inDOMUtils::GetCSSStyleRules(nsIDOMElement*, nsISupportsArray**

http://hg.mozilla.org/qa/mozmill-tests/file/default/firefox/testInstallation/testBreakpadInstalled.js	

http://crash-stats.mozilla.com/report/index/921b3b8b-9a91-4f9e-b885-2b7282091201

	200912010549	200912010549	1552531	Firefox	3.6b4	20091124213835	1.9.2	Windows NT	6.1.7100	x86	0xfffffffff0de7fff		\N

Comment 10

9 years ago
er scratch comment 9, that should have been

20091128-crashdata.csv:

NewGCThing<JSFunction>	

http://get.adobe.com/flashplayer/	
http://crash-stats.mozilla.com/report/index/cb886c25-9cb6-4ee8-97e3-b03a42091128

200911281432	200911281433	68	Firefox	3.6b3	20091115182845	1.9.2	Windows NT	6.0.6002 Service Pack 2	x86	0x28	530961	Mozmill IDE Crash Report
Thanks Chris. I'm in contact with the reporter.
The reporter was trying to reproduce the crash which has been reported on bug 500538. Eventually it would help us here. I will check tomorrow if the signature has been changed when running the given Mozmill test on bug 500538.
This could probably be a dupe of bug 500538. Nearly all of the given signatures seems to be reproducible with the Mozmill test on bug 500538 - at least what the reporter said. I will come back with more information tomorrow.
Not blocking.  It's been around for a while, and it's still relatively low on the top crash list.  If things change, we'll reconsider.
Flags: blocking1.9.2? → blocking1.9.2-

Comment 15

9 years ago
current 3day rank is #236 for 3.6b4 with around 20 crashes per day.
Henrik - Does this bug still need the qawanted keyword?
(In reply to comment #16)
> Henrik - Does this bug still need the qawanted keyword?

I cannot answer. Given my comment 13 someone who is familiar with that stuff should have a look at. CC'ing timeless and peterv.
(Reporter)

Comment 19

5 years ago
Closing as I don't see this exact bug happening any more.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jst)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.