Mail Attachment get corrupted when memory is low

VERIFIED WORKSFORME

Status

P1
major
VERIFIED WORKSFORME
19 years ago
11 years ago

People

(Reporter: bugzilla, Assigned: bugzilla)

Tracking

Trunk
mozilla1.0
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

19 years ago
When I send a big attachment, it get corrupted. it's very easy to see the 
problem using a JPEG of about 75K. However, I don't see the problem with a 20K 
file.

step:
1) compose a message
2) either attach a jpeg file or insert it into the message body. The file should 
be at least 70K
3) send the message
4) retreive the message with either Mozilla or 4.x
5) ==> the image won't display correctly, the bottom of the image is missing!
(Assignee)

Updated

19 years ago
Keywords: correctness, nsbeta3

Updated

19 years ago
QA Contact: esther → pmock
(Assignee)

Comment 1

19 years ago
change priority to P1 as it's a data loose.
Priority: P3 → P1

Comment 2

19 years ago
Please attach the source from the message to see if this is a send side or 
rendering issue.

- rhp
Status: NEW → ASSIGNED
(Assignee)

Comment 3

19 years ago
it's not a rendering issue. I have tried with compressed file (.sit). Unstuffit 
is not able to read it when I sent a large file bug it's fine with a small one. 
I choose jpeg as sample because it's easier to see the problem. Anyway, I will 
attach two message, one sent with mozilla, the second one sent with 4.x...

Comment 4

19 years ago
Is this Mac only?  Can anyone else repro this?
Whiteboard: [b3 need info]
(Assignee)

Comment 5

19 years ago
I haven't tested it on Windows yet because my build isn't done!
(Assignee)

Comment 6

19 years ago
Created attachment 14954 [details]
Image send from Mozilla which is corrupted
(Assignee)

Comment 7

19 years ago
Created attachment 14956 [details]
Image send from Mozilla which is corrupted (again, better line feed)
(Assignee)

Comment 8

19 years ago
Created attachment 14957 [details]
Image sent from 4.x which is good

Comment 9

19 years ago
fyi,
I could not reproduce this bug on win32, linux, and macos using todays build.  I 
tried using different files attachment including the Jeff's image. Jeff thinks 
it could be an issue of low memory on his system.  Jeff is investigating.  

Comment 10

19 years ago
Can I close this out?

- rhp
(Assignee)

Comment 11

19 years ago
let me do more testing first...
(Assignee)

Comment 12

19 years ago
Ok, the bug occurs only when I am low of memory on my Mac. Reassign this bug to 
myself for futur investigation. I don't think so we should hold PR3 for that.
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW
Summary: Mail Attachment get corrupted → Mail Attachment get corrupted when memory is low
Whiteboard: [b3 need info]

Comment 13

19 years ago
nsbeta3- since you're futuring it.
Whiteboard: [nsbeta3-]
Target Milestone: --- → Future
(Assignee)

Comment 14

18 years ago
Accepting
Status: NEW → ASSIGNED
OS: All
Target Milestone: Future → mozilla0.9

Comment 15

18 years ago
changing milestone to unknown.  It will get changed back when we figure out what
milestone to put this bug in.
Target Milestone: mozilla0.9 → ---

Comment 16

18 years ago
Assign it to myself.
QA Contact: pmock → fenella

Comment 17

18 years ago
To Esther ..
QA Contact: fenella → esther
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.6

Comment 18

17 years ago
moving to 0.9.7
Target Milestone: mozilla0.9.6 → mozilla0.9.7

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.9

Updated

17 years ago
Keywords: nsbeta3 → nsbeta1+
Whiteboard: [nsbeta3-]

Updated

17 years ago
QA Contact: esther → trix
(Assignee)

Comment 19

17 years ago
I am running out of timw, it wont make it for 0.9.9. Moved to 1.0
Target Milestone: mozilla0.9.9 → mozilla1.0
(Assignee)

Comment 20

17 years ago
Since this bug has been reported, the code has change a lot. I did the following
test with various memory setting to push Mozilla to the limite of a memFullErr
crash:

1) Open the browser
2) Drag&Drop a 750K image
3) Select Send Page
4) address the message to myself
5) send the message
6) Check the received image from another computer

The normal memory setting for Mozilla is 28672K. At 7000, we crash while trying
to open the image, at 7100K, we crash while typing the email address, at 7200K,
we crash during the send and at 7250K the message get sent and we crash during
the copy but the image is correctly received. All the crash occurs in various
location in Layout/XUL because we run of memory.

As I am not able anymore to reproduce the corrupted image: WFM.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 21

17 years ago
verified wfm
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.