Closed Bug 531065 Opened 11 years ago Closed 11 years ago

After upgrading to Thunderbird 3 RC1 , and reinstalling Lightning 1.0pre, can no longer access local calendars

Categories

(Calendar :: Provider: Local Storage, defect)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 529853

People

(Reporter: paulo.vilela, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.9.1.5) Gecko/20091109 Ubuntu/9.10 (karmic) Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.9.1.5) Gecko/20091121 Lightning/1.0pre Thunderbird/3.0

I have just upgraded from Thunderbird 3 beta 4 to Thunderbird 3 RC1.
When I restarted Thunderbird, I get the messaging saying that the Lightning and the Gdata extensions were no longer valid.
I went to ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-1.9.1/linux-xpi/ and downloaded the 24th November 2009 version of lightning.xpi and gdataprovider.xpi. 
Now when I start Thunderbird I can not access  the 3 local calendars i had configues, as I get these 3 error messages:

1) An error has ocurred
An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.
Details:
Error Code: 0x80004005
Description: [Exception..."Component returned failed code: 0x80004005 (NS_ERROR_FAILURE) [moz|StorageStatement.reset]" location: "JS frame :: file:///home/pvilela/.thunderbird/mpenen0a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 420 data:no]

2) An error has ocurred
An error was encountered preparing the calendar located at moz-profile-calendar://?id=2 for use. It will not be available.
Details
Error Code: 0x80004005
Description: [Exception..."Component returned failed code: 0x80004005 (NS_ERROR_FAILURE) [moz|StorageStatement.reset]" nsresult:"0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///home/pvilela/.thunderbird/mpenen0a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 420 data:no]

3) An error has ocurred
An error was encountered preparing the calendar located at moz-profile-calendar://?id=3 for use. It will not be available.
Details
Error Code: 0x80004005
Description: [Exception..."Component returned failed code: 0x80004005 (NS_ERROR_FAILURE) [moz|StorageStatement.reset]" nsresult:"0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: file:///home/pvilela/.thunderbird/mpenen0a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 420 data:no]



Reproducible: Always

Actual Results:  
Cannot access local calendars
I have a remote Sun calendar that works OK

Expected Results:  
I should be able to access the three local calendars
Summary: After upgradinf tp Thunderbird 3 RC1 , and reinstalling Lighntning 1.0 pre, can no longer access local calendars → After upgrading to Thunderbird 3 RC1 , and reinstalling Lightning 1.0pre, can no longer access local calendars
YEs! That extension fixed it! Thanks
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529853
You need to log in before you can comment on or make changes to this bug.