If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Core Graveyard
Profile: Migration
P3
normal
VERIFIED DUPLICATE of bug 52181
17 years ago
a year ago

People

(Reporter: Waldemar Horwat, Assigned: dbragg)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I did a clean install of today's (September 18) Netscape 6 (I wiped out the old 
Mozilla, Mozilla Registry, and Documents:Mozilla folder hierarchy).  After 
startup, it showed my IE Favorites in the bookmarks menu but didn't find my 
Communicator 4.7.5 bookmarks.  It's nice that we make upgrading from our 
competitor's browser easy, but I don't think we should forget about users 
upgrading from our own browser :-).

My 4.7.5 bookmarks are in the usual place: "Telemark:System 
Folder:Preferences:Netscape Users:Waldemar Horwat:Bookmarks.html".  Communicator 
4.7.5 has no trouble finding them.  That is the only 4.7.5 profile I have.

    Waldemar
(Reporter)

Updated

17 years ago
Keywords: nsbeta3

Comment 1

17 years ago
waldemar, honestly I forget just what happens on a clean install, ie were you just launched
into seamonkey with a default profile or were you presented with the Profile Manager and
asked to create the 'Default User' profile or offered the opportuity to migrate/use your pre-
existing 4.x profile.

Only if you migrated your 4.x profile would you see your 4.x bookmarks. Otherwise you
would have to use the 'Import' command in Manage Bookmarks.
The 'Imported IE Favorites' menu just points to whatever is in C:\WINDOWS\Favorites at
the time. Made possible because our competitor's browser is so closely tied to their OS :-)

So if you migrated your profile and don't have your bookmarks that's a bug. Otherwise,
the behavior was just contrary to your expectation.
(Reporter)

Comment 2

17 years ago
I tried both the Netscape6-mac.sea.bin and the MacNetscape6Installer.sea.bin 
methods; the results are the same in either case.  I get the activation screen, 
asking me if I want to sign up for Netcenter.  I say no and it asks if I really 
don't want to sign up for it.  I say no (cancel) again, and it puts me into the 
browser.  The bookmarks include my current IE Favorites but not any of my 
Netscape 4.7.5 bookmarks.

There is no "C:\WINDOWS\Favorites" on my computer.  It's a Macintosh.  For that 
reason I also don't believe that IE is tied so closely to the OS that we should 
by default import IE bookmarks but not Netscape's.

Comment 3

17 years ago
nav triage team:
We only import Netscape bookmarks automatically if you migrate your profile 
(which is what it does by default).  If you do not migrate your old profile 
(which includes your home page, etc), Netscape bkms are not migrated.

Yes, weird that we have the IE Favorites (not really imported - just a link to 
the Favorites folder on the computer), but that is according to spec.

marking invalid, nsbeta3- . if you are having migration problems, create a 
different bug
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Whiteboard: [nsbeta3-][cut 0920]
(Reporter)

Comment 4

17 years ago
OK, but it currently doesn't migrate the Netscape profile by default, nor does it 
pop up any alert or instructions on how I can do so manually.  It does migrate IE 
bookmarks by default.
(Reporter)

Comment 5

17 years ago
I spoke with jar about this.  He recommended that I reopen the bug.  The problem 
appears to be that migration is either not running at all or running but not 
detecting my 4.7.5 browser.

I've never seen migration actually working, so I don't even know when it's 
supposed to run.  The installer doesn't offer to migrate anything for me.  When I 
launch 6.0 for the first time, it pops up an Activation dialog, asking me whether 
I want to sign up for Netcenter.  I do not want to have a Netcenter, webmail, or 
instant messenger account, so I cancel.  It then asks me if I am sure.  If I 
click the default button, it just puts me back at the previous dialog, so I am 
forced to click cancel to continue.  After that I get the default home page.

When was migration supposed to happen?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: Netscape 6 doesn't import 4.7.5 bookmarks → Migration not working
Whiteboard: [nsbeta3-][cut 0920]
(Reporter)

Comment 6

17 years ago
Changing component to Profile Migration.
Assignee: slamm → dbragg
Status: REOPENED → NEW
Component: Bookmarks → Profile Migration
QA Contact: claudius → gbush

Comment 7

17 years ago
Waldemar,
Migration (and in your case I think-automigration) was NOT happening on the two 
builds referenced her (9/18 and 9/20).  See bug 52181-which was fixed in todays 
builds.
You are correct to remove Documents folder which now contains both the registry 
and Users50 folder (containing profile info)- that will remove any knowledge of 
previous profiles created in 6.0 and allow next launch to get the profile info 
from 4.x and automigrate.  
Upon launch you should see a  confirmation dialog that this profile was created 
in 4.x version and if you press ok, see the progress dialog followed by the 
Activation screen. (Pressing under13 gets you beyond the confusing cancel 
dialogs- bug 1210 in bugscape). Then when seamonkey launches you should see your 
migrated bookmarks.
I verified that this is fixed today so if you have trouble- I will come by and 
see what I can do.
A duplicate of 52181 I think. If you have different symptoms please elaborate.

*** This bug has been marked as a duplicate of 52181 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
vfy
Status: RESOLVED → VERIFIED

Comment 10

13 years ago
http://www.justdave.net/dave/article.php?story=20050107003727277 -> Fixing
OS: Windows 98
Hardware: Macintosh → PC
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.