sqlite 3.6.20 (or newer) requirement should be in thunderbird 3.0rc1 configure phase

RESOLVED WORKSFORME

Status

Thunderbird
Build Config
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Scott Nelson, Assigned: asuth)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.12) Gecko/2009070811 Red Hat/3.0.12-1.el5_3 Firefox/3.0.12
Build Identifier: thunderbird 3.0rc1

I built thunderbird 3.0rc1.  When I ran it, a popup was generated that said that sqlite was too old (I had sqlite 3.6.19).  So I upgraded to sqlite 3.6.20 (the version released with in the past couple of weeks) and now thunderbird 3.0rc1 is fine.

The SQlite version requirement should be checked during the configure phase.


Reproducible: Always

Steps to Reproduce:
1. start thunderbird 3.0rc1
2. SQlite "too old" popup appears
3. thunderbird exists
Actual Results:  
thunderbird exited.


thunderbird 3.0b4 was fine with SQlite 3.6.19.  It seems odd that this requirement crept in between b4 and rc1.  The developers may want to make sure that SQlite 3.6.20 is actually the required minimum version needed by thunderbird 3.0rc1.
(Assignee)

Comment 1

8 years ago
Hm, yeah, my backport missed this.  Standard8, how do you want to play this?  Just make the change on our release branch?
(In reply to comment #1)
> Hm, yeah, my backport missed this.  Standard8, how do you want to play this? 
> Just make the change on our release branch?

I think we can fix it for 3.0.1 as a wanted bug. If we happen to respin for 3.0 then we could take it there as well, but I'm not fussed otherwise.
Whiteboard: [tb30xwants]
status-thunderbird3.0: --- → wanted
Whiteboard: [tb30xwants]
Assignee: nobody → bugmail
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

8 years ago
I was testing shreeder fine in Mandriva 2010.0 until this cropped up.
Mandriva is at sqlite 3.6.18 so if 3.6.20 is really needed and you are not going to roll back, then any more testing for me is stopped.
TB3.0 release is running fine in Mandriva with sqlite 3.6.18.
asuth: reminder ping
Iiuc, Thunderbird 3.0.x "has" a higher requirement than Gecko 1.9.1.x?
Depends on: 538747
Version: unspecified → 3.0
(Assignee)

Comment 6

8 years ago
3.0.1 mozilla-1.9.1 thunderbird release branch demands 3.6.20 which is what it ships with

3.0.2 mozilla-1.9.1 thunderbird release branch demands 3.6.22 which is what it ships with
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
status-thunderbird3.0: wanted → ---
You need to log in before you can comment on or make changes to this bug.