All users were logged out of Bugzilla on October 13th, 2018

“display: table-cell” elements are drawn wrong most of the times.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: alley.marius, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091105 Fedora/3.5.5-1.fc11 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091105 Fedora/3.5.5-1.fc11 Firefox/3.5.5

CSS Display based table layout does not renders regularly.
Like 50% of the time, the second cell in the table layout is put
below the first one.

Reproducible: Sometimes

Steps to Reproduce:
1. Load the page.
2. If does not happen, reload the page.
3. Goto 2.
Actual Results:  
Most of the times the layout displays like this.
http://marious.110mb.com/browser/v1/r1.png

Expected Results:  
Should always display like this.
http://marious.110mb.com/browser/v1/e1.png

Tried in several builds of Linux, and in Windows XP.
The bug only happens in Firefox and not in Opera, Safari and Chrome.
Did you try a mozilla-central build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/ ?  There have been a lot of issues like this fixed more recently than 3.5.*
Happens in Camino 2.0.1. Used to happen on Firefox, but that seems to have been fixed.

Using a CSS "table-cell" property element, the second cell displays below the first cell instead of beside the 1st cell, as it should. Does not always happen, and sometimes refreshing the page will cause the layout to display properly. Sometimes not.

This works fine in Safari, Firefox (Mac and Windows -- on prior Firefox builds it occasionally did the same thing as described above), Chrome (Mac and Windows), IE8, Opera.

Also, wrapping the "table-cell" elements in a "table" or a "table-row", which should not be necessary (since containing elements are implied) results in one of 3 things: (1) no change in the display, (2) It renders properly, or (3) the left cell is drawn completely across the entire width of the page and the second cell is stacked below it. 

Very strange.
What Gecko version is Camino 2.0.1?  (Its User-Agent string will tell; enter the url "javascript:navigator.userAgent" if you don't know.)
Geko 2009120123.

Here is the User-Agent string:

"Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.16) Gecko/2009120123 Camino/2.0.1 (like Firefox/3.0.16)"
(Reporter)

Comment 5

9 years ago
Resolved in Firefox 3.6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.