Application Launcher Dialog Pops Up on metacafe.com

VERIFIED FIXED in fennec1.0

Status

--
blocker
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: aakashd, Assigned: mfinkle)

Tracking

Trunk
fennec1.0
Bug Flags:
in-litmus +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b4pre) Gecko/20091125 Firefox/3.6b4pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091125 Firefox/3.7a1pre Fennec/1.0b5

Steps to Reproduce:
1. Go to http://m.metacafe.com
2. Click on any video link. Wait for the page to laod
3. Click on the video's image on that page.

Actual Results:
The application launcher dialog pops up. Screenshot:

http://www.flickr.com/photos/42893104@N04/4134750208/

Expected Results:
After a talk with Stuart, the intended behavior is supposed to have the application load automatically.
Flags: in-litmus?
(Reporter)

Updated

9 years ago
tracking-fennec: --- → ?

Updated

9 years ago
tracking-fennec: ? → 1.0+

Updated

9 years ago
Assignee: nobody → mark.finkle

Updated

9 years ago
tracking-fennec: 1.0+ → 1.0-
(Reporter)

Comment 1

9 years ago
This is also happening for tel: and mailto: commands.
(Reporter)

Updated

9 years ago
Severity: major → blocker
Created attachment 418889 [details] [diff] [review]
patch

This patch always calls the default handler application for every situation. I chose to implement as a ContentDispatchChooser override so we could extend the system in the future. Also, dealing with setting "ask" to false for all protocols seemed like a pain.

I tested this patch using the tel: protocol found in Joel's test page. The dialog no longer appears and the tel: number is sent directly to the dialer app on N900 and N810.
Attachment #418889 - Flags: review?(gavin.sharp)
Tested using m.metacafe.com from comment 0. The Media player is launched when you "Open" the file, but it is not played. I don't think the player can load from the command line. We might need to fix the way "Open" works to try and use DBus.
Created attachment 419037 [details] [diff] [review]
patch 2

This patch builds on the first. We now also show a dialog to confirm the user wishes to use an external application to open the link. We allow the user to remember the choice for the given link type.

We still just fallback to the default application handler. We do not allow the user to choose from a list of all handlers. I am not even showing the name of the handler, since the names are crazy stupid - "osso_voip_ui" and "CallUI" for example.

I am also just reusing strings from the platform.
Attachment #418889 - Attachment is obsolete: true
Attachment #419037 - Flags: review?(gavin.sharp)
Attachment #418889 - Flags: review?(gavin.sharp)
Comment on attachment 419037 [details] [diff] [review]
patch 2

I think I'd prefer to not offer the checkbox here, given that we don't have UI to reset it.
Attachment #419037 - Flags: review?(gavin.sharp) → review+

Comment 7

9 years ago
Comment on attachment 419037 [details] [diff] [review]
patch 2

a=me
Attachment #419037 - Flags: review+
pushed with requested changes:
https://hg.mozilla.org/mobile-browser/rev/44cf520a5194
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → RC
(Reporter)

Comment 9

9 years ago
verified FIXED on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091228 Firefox/3.6b5pre Fennec/1.0b6pre
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

9 years ago
OS integration tests in litmus now take care of app dialog issues:

https://litmus.mozilla.org/show_test.cgi?id=11797
https://litmus.mozilla.org/show_test.cgi?id=11798
https://litmus.mozilla.org/show_test.cgi?id=11799
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.