Lightning only allows user to input one attendee with LDAP address completion and corrupts upon re-entry

RESOLVED DUPLICATE of bug 492069

Status

RESOLVED DUPLICATE of bug 492069
9 years ago
8 years ago

People

(Reporter: david.marable, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091105 Fedora/3.5.5-1.fc12 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.5) Gecko/20091125 Lightning/1.0pre Shredder/3.0.1pre

When adding a new event and in Invite Attendees window, user can get attendees email through LDAP auto completion for only the first entree. All other entrees, auto completion does not work. Free/busy works well for this first attendee.

If user enters valid email addresses in other attendee fields, free/busy works correctly. But these must be entered by user type the complete email rather through LDAP autocompletion.

If after user has entered the first attendee through auto-completion and the free/busy works correctly and then exists the Invite Attendees window, returning to New Event window, but then re-enters Invite Attendee again,(possibly to add another attendee) the 1st attendee that was auto-completed and had a correct free/busy now has "No Information" for that attendee. If user exits this window now, the 1st attendee that was entered by autocomplete now reverts back to the letters user entered before the autocompletion kicked in, corrupting the 1st attendee.

Reproducible: Always



Expected Results:  
User should be able to invite multiple attendees through LDAP auto-completion and upon exiting and entering again the names should still remain valid

Linux using latest nightly builds from 11/25/09. Connecting to Exchange 2007 through davmail.

I have tested with thunderbird 2.0 and lightning 0.9 and it works correctly
Whiteboard: dupeme
David, do you see any error messages in the Error Console (menu Tools > Error Console)?
(Reporter)

Comment 2

9 years ago
No, I saw no error messages in the Error Console for the original problem.

I just downloaded the latest version of lightening 1.0prm 12/8/2009 and 12/14/09 version of thunderbird 3.0.1 pre and almost all the problems are fixed except 1. The invitee address still gets corrupt when you exit the "Invite Attendee" window and then return. I believe the problem that I now see is written up in Bug 492069.
David, thanks for your answer. I'll resolve this bug as duplicate of bug 492069.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 492069

Comment 4

8 years ago
I see this as resolved, so might be best to open a new bug, but problem seems similar. When using LDAP for address lookup in Lightning 1.0b1, first search completes, but BIND never closes, preventing additional invitee lookups.
You need to log in before you can comment on or make changes to this bug.