Weave forget bookmark's folder

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: sugita, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; ja; rv:1.9.1.5) Gecko/20091123 Iceweasel/3.5.5 (like Firefox/3.5.5; Debian-3.5.5-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; ja; rv:1.9.1.5) Gecko/20091123 Iceweasel/3.5.5 (like Firefox/3.5.5; Debian-3.5.5-1)

I use weave with Iceweasel for 64bit Linux.
My weave forget some bookmark's folder.
After sync, some bookmarks move to "UnsortedBookmarks".

I don't know when it moved.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.syncs background.
2.
3.
Actual Results:  
some bookmarks move to "Unsorted Bookmarks" folder.

Comment 1

9 years ago
I have the same issue. Weave Sync 1.0, FF 3.6, WinXP SP3. A lot of my bookmark folders have Cyrillic names, maybe it is the reason? Here's a typical line from the activity log while bookmarks were restored from weave server:

2010-02-09 00:10:43	Store.BStore         DEBUG	created bookmark 1591 under 5 at -1 as iXBT Hardware http://www.ixbt.com/

Comment 2

9 years ago
No, I was wrong. Weave puts all bookmarks except ones in root bookmark folder to Unsorted Bookmarks, then waits for a while and syncs bookmarks again. After second sync we get bookmarks look like we expected.

Comment 3

9 years ago
From comment 2, it sounds like it's just partial sync where the bookmarks temporarily sit in unsorted until the containing folder is synced. And it sounds like the bookmark ended up in the right place after it synced again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Component: Needs Triage → General
QA Contact: needstriage → general
You need to log in before you can comment on or make changes to this bug.