[HTML5][Patch] script between head and body is not executed

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: nanto, Assigned: hsivonen)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 414833 [details]
Testcase: script between head and body

Script elements written between the head element's end tag and the body element's start tag doesn't execute their scripts when html5.enabled is true.  This bug makes livedoor Reader [1] not work.
[1] http://reader.livedoor.com/reader/ (written in Japanese, an account is required to use the service)

See the attachment to reproduce the bug.
Actual: "Failed"
Expected: "OK"

Confirmed on Gecko/20091126 Minefield/3.7a1pre.

Comment 1

9 years ago
I ran into the same issue on https://investing.schwab.com/trading/start , I used "Report Broken Web Site" to report problem RMO12596395171178.
With html5.enabled, this login page doesn't work and gives "Error: setFocusOnLoginField is not defined" and "loginSubmit is not defined" in the JavaScript Error Console.  In the HTML source the script tag that defines these is between the head element's end tag and the body element's start tag.

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20091130  Minefield/3.7a1pre
(Assignee)

Updated

9 years ago
Priority: -- → P1
(Assignee)

Updated

9 years ago
Duplicate of this bug: 533085
(Assignee)

Comment 3

9 years ago
My guess is that repopping the head pointer puts the op queue in a bad state.
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 4

9 years ago
Created attachment 416363 [details] [diff] [review]
Make headPointer push/pop silent
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Summary: [HTML5] script between head and body is not executed → [HTML5][Patch] script between head and body is not executed
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/9cf7a6383087
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.