Hang on shutdown update from beta3 to beta4 -- unexpected error occurred (error code -1712)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
3 years ago

People

(Reporter: chris hofmann, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-02-21])

(Reporter)

Description

9 years ago
This morning I go the message that beta 4 was available on my Macbook Pro

clicked on the link to accept the update and restart.
windows shut down
but then the restart didn't seem to happpen
clicked on the finder link to the application
waited for a long time, but no response
finally I see a finder dialog
   The operation could not be completed
   An unexpected error occurred (error code -1712)
      (Ok)
(Reporter)

Comment 1

9 years ago
looks like although all the windows shutdown, the old instance of b3 was left running.

I killed it with force quit,  then was able to get b4 started.

10 windows and many tabs from the previous session in each came up fine.  also had chatzilla running in the previous session so it might have been behind the hang at shut down.

do we have a stress test for shutdown/upgrade?
Keywords: hang, testcase-wanted
(Reporter)

Comment 2

9 years ago
Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4

is what I'm running now, but it was b3 that experienced the hang.
(Reporter)

Comment 3

9 years ago
we should check feedback channels to see of other see the same problem.
Component: General → Migration
Flags: blocking-firefox3.6?
QA Contact: general → migration
Summary: Update to beta4 failed → Hang on shutdown durning update from beta3 to beta4 -- many tabs and windows open
When we have evidence that N > 1 on this issue, please renominate!
Flags: blocking-firefox3.6?

Comment 5

7 years ago
chris, do you still see shutdown hangs?
Not sure what component this belongs in because we don't know the cause of the hang.  Moving out of migration since it doesn't seem to be related to migrating data from other browsers.
Component: Migration → General
QA Contact: migration → general

Comment 7

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #5)
> chris, do you still see shutdown hangs?

do we even know that it still exists?  Chris?
Summary: Hang on shutdown durning update from beta3 to beta4 -- many tabs and windows open → Hang on shutdown update from beta3 to beta4 -- unexpected error occurred (error code -1712)
Whiteboard: [closeme 2012-02-21]
(Reporter)

Comment 8

6 years ago
works for me.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.