Charset override does not work on HTTP charset from server

VERIFIED DUPLICATE of bug 72299

Status

()

Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 72299
18 years ago
17 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Shanjian Li)

Tracking

({intl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Charset override does not work on the documents from HTTP charset from server.

Steps of reproduce
1. Go to above URL
2. Select menu View|Character Coding 
   Japanese (EUC-JP) is marked.
3. Select menu View|Character Coding -> More ->East Asia ->Japanese(Shift-JIS)
4. Select menu View|Character Coding 
   Japanese (EUC-JP) is still marked.
   It should be override.

Accoding the specs as follows.
Charset Override: 
The user action of a menu change can also lead to overriding the effect of 
charset determination by 1) HTTP charset from server, 2) Document Meta-charset 
info in the document, 3) the result of auto-detection, or 4) prior user
selection/fallback of the charset.

in 
http://rocknroll/users/momoi/publish/seamonkey/5_0intlbrowsermenudft2.html

Tested 2000-09-18-05 Win32, and 2000-09-18-08 Mac and Linux build.

Updated

18 years ago
Status: NEW → ASSIGNED
Summary: Charset override does not work on HTTP charset from server → Charset override does not work on HTTP charset from server

Comment 1

18 years ago
Mark it as M25. Not sure we really need to fix this.
Target Milestone: --- → M25

Comment 2

18 years ago
Mark it as M23
Target Milestone: M25 → M23
(Reporter)

Comment 3

18 years ago
Added intl and nsbeta1 keywords.
Keywords: intl, nsbeta1

Comment 4

18 years ago
move all cata's bug to ftang
Assignee: cata → ftang
Status: ASSIGNED → NEW

Comment 5

18 years ago
*** Bug 66995 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
shanjian- can you take a look at this ?
Assignee: ftang → shanjian
(Reporter)

Comment 7

18 years ago
Changed QA contact to andreasb@netscape.com for now.

Comment 8

17 years ago
add bstell and yokoyama to the cc list.
(Assignee)

Comment 9

17 years ago
I believe this is a duplicate of 72299.

*** This bug has been marked as a duplicate of 72299 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

17 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.