when the file "inbox" have more of 2gb, the messages are received in blank

RESOLVED DUPLICATE of bug 462665

Status

RESOLVED DUPLICATE of bug 462665
9 years ago
6 years ago

People

(Reporter: cpd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Thunderbird version 2.0.0.23 (20090817)

in some computers, when the "inbox' file" exceed 2gb some messages are modified to a blank page and others are received with undentified caracteres.
Anyway this messages can be read at webmail without any changes, but in thunderbird the changes occur and the problems only stop when i condense the folder and recreate the link to the file "msf" in the user's folder.
Well, what i like to know is:
Why that problem occur, and if that is normal.
Thank you.

And sorry any troubles with the vocabulary, thats only occur because i speak other language and don't have much pratice with the english.

Reproducible: Always

Steps to Reproduce:
1.Have 2gb or more in the "inbox' file" on the user's folder
2.receive a message on the thunderbird from any contact
3.open a message received in the thunderbird
Actual Results:  
the message are blank or with strange caracteres

Expected Results:  
open the correct message with the correct text or image
You're msf file is corrupted. And it's not due to the size (limit on linux is 4Gb).

Right click on your inbox file - select properties - click rebuild. This should solve your issue.
Group: core-security
4GB is written in bug summary of Bug 387502, but limit is 2GB on Linux/Mac.  Bug 387502 produces file greater than 2GB on Linux.

Once file size exceeds limit(2GB on Linux), rebuild index can't handle mail data at greater than 2GB properly (probably offset value is wrapped). 
Keep backup of Inbox ASAP if problem happens, show "Order Received" column (offset in Inbox), try to move older/healthy mails as many as possible, compact (you say "condence") and check file size, and execute rebuild-index (similar to your delete of Inbox.msf") if less than 2GB.

"Compact" may corrupt mail data placed at greater than 2GB due to wrap around of offset. If recovery by above failed, split bakup of Inbox(an "unix mbox" file. serach at Google, please) by tool/utility or simple script.
you should be dup of bug 462665.

Until 3.0 on Linux, limit is 2GB.  If over 2GB, this problem occurs.  3.1 on Linux is extended to 4GB by bug 538512.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462665

Comment 4

6 years ago
there are ways of not hitting 32-bit limits. use 64-bit integers and 64-bit filesystem stuff. for instance, fread, fwrite, fopen have 64-bit equivalents.
for instance,
fgetpos()
fsetpos()
fgetpos64() (same as above)
fsetpos64()

in the mingw-w64 (gcc) compiler.
I wrote an inbox splitting program called tbmailsplit. I am about to re-release it with a merging utility should the problem get fixed (but the emails won't be in order if you split multiple times).

really, this kind of thing should be fixed. the only limit on the email client should be the filesystem 1st (which is nowadays 64-bit) and 2nd the memory (which is now 64-bit usually too).

so - are you coming out with a 64-bit version of tb?
You need to log in before you can comment on or make changes to this bug.