Firefox 3.6b4 process does not terminate when window is closed




8 years ago
8 years ago


(Reporter: Frank, Unassigned)


({hang, regression})

3.6 Branch
Windows Vista
hang, regression

Firefox Tracking Flags

(Not tracked)




(2 attachments)



8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)

When using Firefox 3.5 Beta 4, the process will not terminate when the window is closed. Im not quite sure if its a Firefox issue or a Windows issue as I have not tested it on a Linux or Solaris system. Its just really annoying to have to use task manager to terminate the process. 

Sidenote: I also have a build of Firefox 3.5.5 installed for comparison testing but it doesn't do this when I close it. Will include dump file and screencap in attachments

Reproducible: Always

Steps to Reproduce:
1.Open Firefox 3.6 beta 4
2.Close window
3.Try to open any Firefox Build with any Profile
4.Error message stating that Firefox is already running
5.Open task manager to terminate process
Actual Results:  
Process terminates only through task manager

Expected Results:  
Firefox process should terminate when window closes

Bug occurs with default theme as well as Nautopolis version 1.8.52

Built from
Build platform

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1

Configure arguments
--enable-application=browser --enable-update-channel=beta --enable-update-packaging --enable-jemalloc --enable-official-branding
Do you get this with the safemode : ?

Do you have the Zonealarm toolbar installed ?

Comment 2

8 years ago
No I don't. I do have the Norton toolbar installed though its disabled as it isnt compatible with 3.6 

Actually, for reference purposes, here's the list of my extensions.

Add-on compatibilty reporter 0.4, 
Chatzilla 0.9.85, 
Foxlingo 2.5.1, 
Header spy, 
Infocon monitor 0.3.1, 
Live HTTP headers 0.15, 
Microsoft .NET Framework assistant 1.1, 
Norton IPS 1.0, 
Norton Toolbar 3.7, 
RealPlayer Browser Record Plugin 1.0, 
TorButton 1.2.2, Update Channel Selector 1.5, 
WinAmp Toolbar

Norton Toolbar is incompatible with this build so its disabled.

Also, Ive run it in safe mode and it still happens, but only after its been running for more than a half hour and thats the same with it when it has its addons running. Next time it happens im getting a screencap and memory dump which ill include in the attachments.

Comment 3

8 years ago
Attached a dump file and a screen capture of the error message and the task manager.

Comment 4

8 years ago
Created attachment 414905 [details]
Screen Capture of error message and task manager

Firefox is using too much memory and wont close without killing the process in the task manager from what this capture shows

Comment 5

8 years ago
Created attachment 414939 [details]
WinDbg stacktrace for Firefox

The stacktrace really doesnt show anything related to the bug I dont think, im including it anyway.


8 years ago
Severity: major → critical
Keywords: hang, regression
Version: unspecified → 3.6 Branch
How many bookmarks and history entries has this profile?

Comment 7

8 years ago
Zero. None of my bookmarks from 3.5.5 carried over to any beta past 3.6b 2, and it hasn't been recording history since then either.
Does the same happen in a fresh profile? Any plugins which could interfere here?

Comment 9

8 years ago
Yes it does, always. Doesn't matter how 

And as for the second question, not that I can see, but it could be a plugin conflict. Will test and report.

Comment 10

8 years ago
Correction: It doesnt matter what profile you're using, its always occuring.
Do you have Google desktop installed on your box and are you always using the profile manager?

Comment 12

8 years ago
No I don't have Google Desktop. I have google updater but not desktop. And I used the profile manager to load a clean profile to test this bug but it occurs whether or not I use my regular profile with my addons or when I use profile manager to switch.
Can you disable all plugins for that profile and try again after a restart?

Comment 14

8 years ago
I did attempt that, and it continues to occur with b4 no matter what I try to do or change. 
The issue seems to have resolved itsself in 3.6b5 however, it behaves as it should when I close it no matter what profile I run it in, what addons or plug-ins are enabled or disabled, so on and so forth.
Ok, so marking it as WFM for the moment. If you experience this issue again feel free to reopen.
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.