[ACR Extension] "This add-on still works" should be disabled (greyed) when add-on is compatible instead of hidden

VERIFIED FIXED in ACR-0.*

Status

addons.mozilla.org Graveyard
Compatibility Tools
P2
normal
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: J, Assigned: fligtar)

Tracking

ACR-0.*
ACR-0.*

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4

Hi,
When I click on the compatability button for compatabity reporter 0.4 it says that "this add on no longer works". This is on Firefox 3.6.b4 and as far as I know there is no update for compatabity reporter 0.4?

Many thanks 

J

Reproducible: Always

Steps to Reproduce:
1.click on the compatability button for compatabity reporter 0.4 it says that "this add on no longer works"
2.click on the compatability button for compatabity reporter 0.4 it says that "this add on no longer works"
3.click on the compatability button for compatabity reporter 0.4 it says that "this add on no longer works"
Actual Results:  
"this add on no longer works"

Expected Results:  
Not shown that the compatabity reporter 0.4 no longer works

Yes happens with the default theme which is the only theme that i use

Comment 1

9 years ago
The whole point of the Add-on Compatibility Reporter extension is to report add-ons that no longer work in a newer version. That button has two options, "This add-on no longer works" and "This add-on still works", however the later doesn't show if the add-on already lists compatibility with the current Firefox version. In this instance, ACR 0.4 is compatible so it isn't letting you report that it is for no reason.

I think this looks a little odd and apparently can confuse some users. I think it would be better if the other option was disabled (greyed out) in this case instead of hidden. That's normally how this sort of thing should be handled in the GUI.

Maybe changing the options to be prefaced with "report that" would also be more clear?
Component: General → Compatibility Tools
OS: Windows XP → All
Product: Firefox → addons.mozilla.org
QA Contact: general → compatibility
Hardware: x86 → All
Summary: compatabity reporter 0.4 → [ACR] "This add-on still works" should be disabled (greyed) when add-on is compatible instead of hidden
(Assignee)

Comment 2

9 years ago
That's a good idea. I've seen a bunch of confusion about the missing option.

For add-ons that are already compatible, instead of hiding the option, we should have a disabled "Marked as compatible by developer" option without the checkmark image.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Assignee: nobody → brian

Comment 3

9 years ago
(In reply to comment #2)
> For add-ons that are already compatible, instead of hiding the option, we
> should have a disabled "Marked as compatible by developer" option without the
> checkmark image.

Done, r57092. 

Justin, I put a placeholder for the new string in English in each locale. What's the procedure for announcing new strings now?
Status: NEW → ASSIGNED

Comment 4

9 years ago
Created attachment 415383 [details]
New drop down item

Here is what it looks like.
Priority: -- → P3
Target Milestone: --- → BW-1.0.5

Updated

9 years ago
Duplicate of this bug: 533275

Comment 6

9 years ago
-> Justin for evaluation. See comment 3 and comment 4.
Assignee: brian → fligtar

Updated

8 years ago
Priority: P3 → P2
Summary: [ACR] "This add-on still works" should be disabled (greyed) when add-on is compatible instead of hidden → [ACR Extension] "This add-on still works" should be disabled (greyed) when add-on is compatible instead of hidden
Target Milestone: BW-1.1 → ACR-1.0
Version: unspecified → ACR-0.*

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified fixed with latest version of the add-on.
Status: RESOLVED → VERIFIED

Updated

7 years ago
Target Milestone: ACR-1.0 → ACR-0.*
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.