Event when user enter data in text <INPUT> field by doing mouse click on auto-form-save pop-up list

RESOLVED DUPLICATE of bug 320462

Status

()

Core
DOM: Events
--
enhancement
RESOLVED DUPLICATE of bug 320462
8 years ago
4 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
An Event to distinguish the user input on a text <INPUT> field while using click on auto-form-save pop-up list item.

Issue:-
In most of our application we have a text box and "search" button. 
Like

Enter Search text : [__________] <search>

And the user specification says on page load 
the "search" button should be disabled.

When the user enter a valid search characters/text 
then only the search button should be enabled.

And this was how legacy client server application worked, 
which users are used to. 

Now the user can enter text to search by.
1. Typing manually
2. Copy and paste text from else where
3. Pull down auto-form-save pop-up list, and with KEYS selecting one
4. Pull down auto-form-save pop-up list, and with MOUSE selecting one

Case 1, I can handle with keyup, keypressed events
Case 2, possible using onBeforePaste/onPaste, and a short delay timeout
Case 3, possible because of Bug 531494 and keyup, keypressed events
Case 4, NO WAY to trap this unless we run a continues loop of timeout/setInterval 

I wish there was an Event fired for Case 4 (and also may be same for 3 and 2), 
It may be named something like "onFilled"
(Reporter)

Comment 1

8 years ago
also we cant use onchange event
(Reporter)

Updated

8 years ago
Depends on: 320462

Comment 2

7 years ago
FWIW: I'm not sure that auto-form-save is the best name for what you're trying to describe if I understand what you're saying.  Isn't it more of an "text-input-history"?

Furthermore, I've found that utilizing jquery's 'input' event (eg. $(this).live('input',function(){});) is at least a workaround for this problem in the interim.

Credit for the workaround goes to robertc on http://stackoverflow.com/questions/6050948/proper-handling-of-input-change-event

If I've misread your description, please let me know and I'll create a new ticket for my specific problem.

Comment 3

4 years ago
This was fixed by bug 320462, and an 'input' event fires, and has done since Firefox 4. I don't think there's anything distinct about this report, so I'm duping it to bug 320462.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 320462
You need to log in before you can comment on or make changes to this bug.