"ASSERTION: cannot get ptop" when running layout/base/crashtests/378325-1.html

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({assertion, intermittent-failure, testcase})

Trunk
x86
Mac OS X
assertion, intermittent-failure, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 414944 [details]
stack trace

Loading layout/base/crashtests/378325-1.html (with focus) triggers:

###!!! ASSERTION: cannot get ptop: 'ptop', file /Users/jruderman/central/dom/base/nsGlobalWindow.cpp, line 6689

ptop is null because top is null.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 569962

Comment 2

8 years ago
This run didn't cause this assertion at all:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1276548822.1276549542.31065.gz

Comment 3

7 years ago
Likewise, neither did this run:
s: win32-slave17 2010-06-23 11:50a PDT, debug crashtest:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1277316072.1277317760.16451.gz#err0
This assertion is failing sporadically in a new crashtest that was checked in today. I filed bug 844525 for that.
Also, for reference, the crashtest from comment 0 here is currently marked as "asserts(0-99)":
https://mxr.mozilla.org/mozilla-central/source/layout/base/crashtests/crashtests.list#148
Keywords: intermittent-failure
Summary: "ASSERTION: cannot get ptop" → "ASSERTION: cannot get ptop" when running layout/base/crashtests/378325-1.html
Whiteboard: [test marked as asserting]
Testcase no longer asserts on trunk.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Whiteboard: [test marked as asserting]

Comment 7

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/faa7606a5613

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/faa7606a5613

Comment 9

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/faa7606a5613
status-b2g-v2.5: --- → fixed
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
status-b2g-v2.5: fixed → ---
You need to log in before you can comment on or make changes to this bug.