Message list scrolls to top whenever mail is checked

RESOLVED INVALID

Status

Penelope
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Jay Paroline, Assigned: Matt Dudziak)

Tracking

x86
Windows 7

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0RC1 Penelope 0.5a4

When the penelope extension is enabled, the message list view scrolls to the top if sorting by date ascending, or to the bottom if sorting by date descending, regardless of whether the preview pane is visible or a message is selected.

Reproducible: Always

Steps to Reproduce:
1. Sort messages by date
2. Scroll towards the middle of your message list
3. Check mail by clicking the button or waiting for the next automatic check event.
Actual Results:  
Message list scrolls and currently selected message (if any) changes.

Expected Results:  
Message list should remain where user had it and currently selected message should not change.

Behavior reverts to normal with Penelope extension disabled.
(Reporter)

Updated

8 years ago
Version: unspecified → 0.5
(Reporter)

Comment 1

8 years ago
This is still happening for me with the official release of Thunderbird 3.0 with Penelope 0.5a4
(Assignee)

Comment 2

8 years ago
(In reply to comment #1)
> This is still happening for me with the official release of Thunderbird 3.0
> with Penelope 0.5a4

This should be fixed in our next beta.

Matt
(Assignee)

Comment 3

8 years ago
Should be fixed now.

If you are able to reproduce this, please try try to reproduce it in Thunderbird 3.0.1 (http://www.mozillamessaging.com/en-US/thunderbird/). If the problem is present in Thunderbird please file a bug against Thunderbird. If the problem is NOT present in Thunderbird please let me know or re-open the bug here.

Thanks, Matt
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 4

8 years ago
Actually, this is intended behavior.  We call it FUMLUB (First Unread Message of the Last Unread Block) selection.  It can be controlled with the "Select newly inserted messages (FUMLUB)" setting in the Penelope panel of the Options/Preferences dialog.
Resolution: WORKSFORME → INVALID
(Reporter)

Comment 5

8 years ago
0.5a4 is not compatible with 3.0.1 so I can't test. Is there anywhere I can get a newer version that is compatible?

I don't think it's FUMLUB (at least not intended behavior of FUMLUB):
1. Eudora 8 with FUMLUB enabled does not behave this way.
2. The behavior I complained about happens even when no new messages are inserted. Literally just every time there's a check.

However, I will try turning it off if I get a chance to test with 3.0.1.
You need to log in before you can comment on or make changes to this bug.