Last Comment Bug 531612 - [webgl] OSMesa wrapping fails on Linux
: [webgl] OSMesa wrapping fails on Linux
Status: RESOLVED DUPLICATE of bug 565417
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: x86 Linux
: -- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-29 05:31 PST by Ilmari Heikkinen
Modified: 2011-06-12 03:16 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch to glwrap.cpp (326 bytes, patch)
2009-11-29 05:42 PST, Ilmari Heikkinen
no flags Details | Diff | Splinter Review

Description Ilmari Heikkinen 2009-11-29 05:31:39 PST
Using libOSMesa software GL for WebGL doesn't work on Linux because

src/content/canvas/src/nsGLPbufferOSMESA.cpp:165
if (!mGLWrap.Init(GLES20Wrap::TRY_SOFTWARE_GL)) {

fails on Linux. TRY_SOFTWARE_GL seeks symbols named with a "mgl"-prefix, e.g. "mglActiveTexture". The Linux OSMesa uses the "gl"-prefix, so should use TRY_NATIVE_GL instead. A quick workaround is to try both:

if (!(mGLWrap.Init(GLES20Wrap::TRY_SOFTWARE_GL) || mGLWrap.Init(GLES20Wrap::TRY_NATIVE_GL))) {
Comment 1 Ilmari Heikkinen 2009-11-29 05:42:02 PST
Created attachment 414960 [details] [diff] [review]
patch to glwrap.cpp

Uses "gl" on MOZ_X11, "mgl" otherwise.
Comment 2 Reed Loden [:reed] (use needinfo?) 2010-01-11 21:35:29 PST
WebGL isn't on the 1.9.2 branch, so can't block there. ;)
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2010-05-22 15:18:41 PDT
Fixed since bug 565417 has been fixed.
Comment 4 Dão Gottwald [:dao] 2011-06-12 03:16:10 PDT

*** This bug has been marked as a duplicate of bug 565417 ***

Note You need to log in before you can comment on or make changes to this bug.