<arrowscrollbox> is non-functional in in-browser XUL

VERIFIED FIXED in fennec1.0

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: cfinke, Unassigned)

Tracking

Trunk
fennec1.0
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Fennec 1.06bpre

An <arrowscrollbox> used in an XUL file that is loaded inside the browser displays its arrows, but they do not respond to being clicked on.

Reproducible: Always

Steps to Reproduce:
1. Load a file that uses an <arrowscrollbox>.
2. Click on the arrows to scroll the box.

Actual Results:  
Nothing happens.

Expected Results:  
The box should scroll.
(Reporter)

Comment 1

9 years ago
Created attachment 415058 [details]
Contains an <arrowscrollbox> with enough inner elements that it needs to be able to scroll.

Load the attached file as a test case.

Comment 2

9 years ago
bug 460678 patch makes this pannable, although it's true that the arraows are not working.
Status: UNCONFIRMED → NEW
Depends on: 460678
Ever confirmed: true
fixed by bug 460678

the arrowscrollbox is pannable. The buttons, however, are not pressable. That seems to be a separate bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
Using the testcase, I only see a row of repeated "ABC" text along the top of the content window on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091201 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091201 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Right, and those "ABC..." are in an arrowscrollbox. The box does scroll if you pan on the letters
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
ah thanks! I didn't see that. verified FIXED on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091201 Firefox/3.6b5pre Fennec/1.0b6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.