Closed Bug 531786 Opened 10 years ago Closed 10 years ago

Application Name (Fennec) should not be hardcoded in installer file (setup.ini)

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec1.0a4-wm+)

RESOLVED FIXED
Tracking Status
fennec 1.0a4-wm+ ---

People

(Reporter: bugzilla, Assigned: alexp)

References

Details

Attachments

(1 file, 1 obsolete file)

Currently Fennec's installer file have hard corded brand names within setup.ini:
http://hg.mozilla.org/mobile-browser/file/tip/locales/en-US/installer/setup.ini

But for official releases, we must change it from "Fennec" to "Firefox".
They should use $BrandShortName (or $AppShortName) as Firefox do.

This have l10n impact and we should handle this soon.
Requesting blocking-fennec.
If setup.ini will not be used in official build, reject blocking request.
tracking-fennec: --- → ?
Duplicate of this bug: 531908
Whiteboard: [fennec l10n]
Assignee: nobody → alexp
Attached patch Fix (obsolete) — Splinter Review
Use %MOZ_APP_DISPLAYNAME% in setup.ini, and replace it from locales/Makefile.
Attachment #416204 - Flags: review?(robert.bugzilla)
Alex, I just saw this request and am unsure exactly when I'll be able to get to it. It would normally be quick for this type of change but I haven't had a chance to look at how the recent changes to packaging made by ted and axel work yet. Since it appears that all of the changes are under mobile you might get a quicker review by someone on the mobile team if this is time sensitive.
btw: applying the patch and doing an incremental build didn't replace MOZ_APP_DISPLAYNAME in the installer for me when testing with an emulator... perhaps a clobber is required?
Alex, I did a clobber then make installer and it appears to be using the setup.ini from the src dir and not the preprocessed one.
Hey, nice catch! Somehow I missed that. That's what reviews are for! :)
Yes, installer Makefile got the setup.ini from the source dir because we didn't copy it anywhere before. It has to be updated too.
Attachment #416204 - Flags: review?(robert.bugzilla)
Attached patch Updated fixSplinter Review
Added installer Makefile change to the patch. It gets the processed setup.ini and packs it into a setup executable.
Attachment #416204 - Attachment is obsolete: true
I noticed that the destination for the setup.ini is dist/bin... I personally prefer not cluttering up this directory when possible. We use other dirs for Firefox (sometimes in the root of the obj-dir, another time under browser/installer/windows/instgen, and yet other times under dist/install.
setup.ini is used by uninstall.exe, both of them go into the main Fennec directory on a device (which is based on dist/bin). Any suggestions on a more appropriate location for that are welcomed.
I forgot it was read by uninstall.exe and if it is actually part of the distribution then this is fine.
Attachment #416299 - Flags: review?(robert.bugzilla)
Attachment #416299 - Flags: review?(mark.finkle)
Comment on attachment 416299 [details] [diff] [review]
Updated fix

Talked with Ted about the LOCALE_MERGEDIR and I'm comfortable +'ing that part as well. r=me as long as you've also built / tested this.
Attachment #416299 - Flags: review?(robert.bugzilla) → review+
Attachment #416299 - Flags: review?(mark.finkle) → review+
Summary: Application Name (Fennec) should not be hard corded in installer file (setup.ini) → Application Name (Fennec) should not be hardcoded in installer file (setup.ini)
btw: the l10n tinderboxen won't catch this change since the names aren't changing. One thing you can do is check for the existence of part of the string (e.g. Fennec) similar to
http://mxr.mozilla.org/mozilla1.9.1/source/toolkit/mozapps/installer/windows/nsis/check-locales.pl

though I'd recommend using python
tracking-fennec: ? → 1.0b1-wm+
Keywords: checkin-needed
Attachment #416299 - Flags: approval1.9.2.1?
tracking-fennec: 1.0b1-wm+ → 1.0a4-wm+
Attachment #416299 - Flags: approval1.9.2.1?
Whiteboard: [fennec l10n] → [fennec l10n] [fennec-checkin-post1.0]
pushed http://hg.mozilla.org/mobile-browser/rev/942cf00afc9c
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
what is checkin-needed here?
(In reply to comment #15)
> what is checkin-needed here?

Nothing. Sorry.
Whiteboard: [fennec l10n] [fennec-checkin-post1.0]
You need to log in before you can comment on or make changes to this bug.