Closed Bug 531897 Opened 10 years ago Closed 10 years ago

plugins in iframes do not work

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

ARM
Maemo
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: dougt, Assigned: stechz)

References

Details

Attachments

(1 file)

We are not calling SetAbsoluteScreenPosition() on any embed/object elements that exist in iframes

For example, 

http://play.clubpenguin.com/

uses an iframe to host its flash content:

http://play.clubpenguin.com/iframe_index.php?aff=0&lang=en&p=1
tracking-fennec: --- → ?
Status: NEW → ASSIGNED
Assignee: nobody → webapps
Duplicate of this bug: 533593
Attached patch PatchSplinter Review
Attachment #416807 - Flags: review?(mozbugz)
Comment on attachment 416807 [details] [diff] [review]
Patch

this doesn't address iframes that specify a smaller size than the source document, but that can be a follow up bug.
Attachment #416807 - Flags: review?(mozbugz) → review+
Blocks: 534251
http://hg.mozilla.org/mobile-browser/rev/8545de40c731
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091214 Firefox/3.6b5pre Fennec/1.0b6pre
Status: RESOLVED → VERIFIED
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.