Closed Bug 531925 Opened 10 years ago Closed 10 years ago

Duplicate updates showing up in the update queue

Categories

(addons.mozilla.org Graveyard :: Admin/Editor Tools, defect, P5, trivial)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: eviljeff, Assigned: smccammon)

References

()

Details

(Whiteboard: [ReviewTeam])

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: 

https://addons.mozilla.org/en-US/editors/review/82964?num=6
and
https://addons.mozilla.org/en-US/editors/review/82966?num=5
are the same addon and the same version but the review is there twice.

It may be caused by the user uploading the version twice but the site should still handle it and only have the latest version in the queue.

Reproducible: Sometimes




can be fixed by using admin control panel (most editors don't have the rights)
or by denying the other update (probably confusing for the author)
I can confirm this. What's the num parameter for anyway?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Priority: -- → P3
Hardware: x86 → All
Summary: Duplicate updates showing up in the update quee → Duplicate updates showing up in the update queue
Whiteboard: [required amo-editors]
Target Milestone: --- → 5.5
(In reply to comment #1)
> What's the num parameter for anyway?

its just for the order in the queue so the 'next' & 'previous' links work - not that I've ever used them to navigate in that way.
Severity: minor → trivial
Priority: P3 → P5
Target Milestone: 5.5 → 4.x (triaged)
Attached patch Patch, v1Splinter Review
The only way I could reproduce was to click "continue" multiple times on the last stage of the file uploader. This creates multiple versions with the same version string, but would not allow a duplicate filename leaving the duplicate version(s) with 0 files.

This patch fixes this case. Are there any other known ways to reproduce this bug?
Assignee: nobody → smccammon
Status: NEW → ASSIGNED
Attachment #417141 - Flags: review?(clouserw)
(In reply to comment #3)
> Created an attachment (id=417141) [details]
> Patch, v1
> 
> The only way I could reproduce was to click "continue" multiple times on the
> last stage of the file uploader. This creates multiple versions with the same
> version string, but would not allow a duplicate filename leaving the duplicate
> version(s) with 0 files.
> 
> This patch fixes this case. Are there any other known ways to reproduce this
> bug?

I'm not really sure of the cause but with the two addons reviews above *both* versions have files.  I've just checked the admin control panel and there was actually a third version
https://addons.mozilla.org/en-US/editors/review/82965
that was made public already.
They were all created within the same minute at least (03:46) so the user submitting 3 versions from scratch is unlikely.

A workaround would be to have the approve/deny code check for other 'pending reviews' (not including other OS versions) and marked them as sandbox. (if we can't work out the root cause)
Attachment #417141 - Flags: review?(clouserw) → review+
Comment on attachment 417141 [details] [diff] [review]
Patch, v1

good catch, anyway
This seems to be ready to be pushed. Right?
Target Milestone: 4.x (triaged) → 5.7
(In reply to comment #6)
> This seems to be ready to be pushed. Right?

Yeah, I'll check-in the patch though it sounds like there are duplicates coming from somewhere else too.

r61804

Please re-open if another way is found to reproduce.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Bug 544037, which is recent, seems to be similar, if not a dupe. It refers to a beta version, though, and it looks like the author didn't click on Submit more than once.
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.