click on search field label doesn't focus search field on mozilla.org site

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: surkov, Unassigned)

Tracking

(Blocks: 1 bug, {access})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
The DOM node of search entry accessible has @id="q".
(Reporter)

Comment 1

8 years ago
The "Search" label for HTML input is placed over it (absolutely positioned), when I click on the label then it doesn't focus the HTML input. So the problem is not in a11y.

Moving into more appropriate component, however I'm not sure it's 100% correct.
Component: Disability Access APIs → Event Handling
QA Contact: accessibility-apis → events
(Reporter)

Comment 2

8 years ago
changing summary
Summary: 'activate' action of search entry on mozilla.org site can't be invoked → click on search field label doesn't focus search field on mozilla.org site

Comment 3

8 years ago
Could this be a problem?
    <li><a href="#q">Skip to Search</a></li>
mozilla.org has changed significantly... is this still an issue? If so, can you provide a testcase?
Flags: needinfo?(surkov.alexander)
(Reporter)

Comment 5

3 years ago
I don't see any searchfield labels anymore, closing the bug
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(surkov.alexander)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.