{inc} layout problems after attributing text.

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
major
VERIFIED WORKSFORME
19 years ago
17 years ago

People

(Reporter: sujay, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] rendering text in editor incorrect)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
using the 4/20 apprunner on Windows 98.

1) Open up this test case in the editor:

<html><body>1234567890abcdefgh</body></html>

2) select from 2-9, make bold
3) select from 2-8, make italic

4) look at the "8" in that string, notice it cuts into the "9" a little bit.
because its italicized.
(Assignee)

Updated

19 years ago
Assignee: buster → kipp
(Assignee)

Comment 1

19 years ago
probably a dup of 4524.  Assigning to Kipp.

Updated

19 years ago
Severity: normal → trivial
Status: NEW → ASSIGNED
Target Milestone: M9
Whiteboard: ascertaining blame, waiting for response...
Target Milestone: M15
As far as I can tell, the line is not being reflowed when style is applied.
Is this a layout bug, or an editor-specific bug?

When a page containing "1<B><I>2345678</I>9</B>0" is rendered in viewer, the
8 and the 9 do not run into each other.
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Comment 3

19 years ago
This would certainly be a layout or DOM bug.  The editor manipulates content.
The layout engine reflows in response to content changed notifications.  Since
we have every reason to believe the DOM is notifying layout correctly, I believe
it's a bug in incremental reflow of inline style frames and/or text frames.
Placed in the M15 holding tank.
Summary: layout problems after attributing text. → {inc} layout problems after attributing text.
Whiteboard: ascertaining blame, waiting for response...

Comment 4

19 years ago
Created attachment 885 [details]
test case (as attachment for convenience)

Updated

19 years ago
Whiteboard: [TESTCASE] rendering text in editor incorrect

Comment 5

19 years ago
Overview description:
 bold and italic text bump into each other in editor

Steps to reproduce:
 1) open attachment in editor
 2) select 2-9 and make bold; select 2-8 and make italic

Actual Results:
 8 and 9 touch each other

Expected Results:
 8 and 9 not to touch each other

Build Date & Platform:
 M7 & 1999071417 build (Win32)

Updated

19 years ago
Target Milestone: M15 → M11

Updated

19 years ago
Severity: trivial → major

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

19 years ago
With current builds, it works for me. There is no difference between incremental
reflowing it (by editing) or by resizing reflowing (by changing the size of the
editor window).
(Assignee)

Comment 7

19 years ago
agreed, seems to work fine now.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

19 years ago
verified in 9/14 build.
You need to log in before you can comment on or make changes to this bug.