If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fontconfig/fcfreetype.h not found during configure check

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
Graphics
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Hanspeter Niederstrasser, Assigned: Hanspeter Niederstrasser)

Tracking

({regression})

Trunk
mozilla1.9.3a1
All
Mac OS X
regression
Points:
---
Bug Flags:
wanted1.9.2 +
in-testsuite -

Firefox Tracking Flags

(status1.9.2 final-fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: 

With the checkin for bug 527980, configure fails on Darwin/X11:

checking for fontconfig/fcfreetype.h... no
configure: error: Can't find header fontconfig/fcfreetype.h.
*** Fix above errors and then restart with               "make -f client.mk build"
make[1]: *** [configure] Error 1


Config.log says:

configure:22269: checking for fontconfig/fcfreetype.h
configure:22279: gcc-4.2 -arch x86_64 -E -isysroot /Developer/SDKs/MacOSX10.5.sdk  -I/sw64/include/freetype2 -I/sw64/include conftest.c >/dev/null 2>conftest.out
configure:22275:35: error: fontconfig/fcfreetype.h: No such file or directory
configure: failed program was:
#line 22274 "configure"
#include "confdefs.h"
#include <fontconfig/fcfreetype.h>

And fontconfig/fcfreetype.h is in /usr/X11/include/fontconfig/fcfreetype.h

Reproducible: Always




Adding $XCFLAGS to $CPPFLAGS in the relevant configure.in test allows the build to finish successfully.
(Assignee)

Comment 1

8 years ago
Created attachment 415407 [details] [diff] [review]
adds XCFLAGS to CPPFLAGS in configure
Attachment #415407 - Flags: review?(benjamin)
(Assignee)

Updated

8 years ago
Blocks: 527980
Keywords: regression

Updated

8 years ago
Attachment #415407 - Flags: review?(benjamin) → review+
(Assignee)

Updated

8 years ago
Flags: wanted1.9.2?
Keywords: checkin-needed
Version: unspecified → Trunk

Comment 2

8 years ago
wanted, but certainly not blocking or urgent given the current schedule
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted1.9.2? → wanted1.9.2+
Perhaps I should have used pkg-config.  For future reference, does that work as expected on Darwin?
(Assignee)

Comment 4

8 years ago
[nieder] $ pkg-config --cflags fontconfig
-I/usr/X11/include
(Assignee)

Comment 5

8 years ago
Comment on attachment 415407 [details] [diff] [review]
adds XCFLAGS to CPPFLAGS in configure

Oops.  That should have been an approval request for 1.9.2 since the patch from bug 527980 landed there as well (although having it wanted is of course nice too :)
Attachment #415407 - Flags: approval1.9.2?
Assignee: nobody → niederstrasser
http://hg.mozilla.org/mozilla-central/rev/b757e80d4fb1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Attachment #415407 - Flags: approval1.9.2? → approval1.9.2+
Comment on attachment 415407 [details] [diff] [review]
adds XCFLAGS to CPPFLAGS in configure

a192=beltzner, post-hoc, reed has been appropriately scolded.
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: needs checkin to 1.9.2 branch
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/094d5802511b
status1.9.2: --- → final-fixed
Keywords: checkin-needed
Whiteboard: needs checkin to 1.9.2 branch
status1.9.2: beta5-fixed → final-fixed
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.