Download Pop-Up Dialog does not block accessing content

VERIFIED FIXED in fennec1.0

Status

Firefox for Android Graveyard
General
--
blocker
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: aakashd, Assigned: mfinkle)

Tracking

Fennec 1.1
fennec1.0

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Build Id:
Mozilla/5.0 (Windows; U; Window3sCE 5.2; en-US; rv:1.9.2b5pre) Gecko/20091201 Namoroka/3.6b5pre Fennec/1.0a4pre

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091201 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091201 Firefox/3.7a1pre Fennec/1.0b5

Steps to Reproduce:
1. Go to the nightly builds page
2. Tap/Click to begin to download any of the files there
3. When the Pop-up Dialog comes up asking you to open,save or nothing, try to pan and click on any of the other links on the page
4. Click on the url bar.

Actual Results:
Fennec UI is pannable and accessible in both the content window and chrome window. It allows the user to click on any links and access the UI without the dialog being removed.

Expected Results:
If the user decides to do other thing with the Fennec UI, the pop-up dialog definitely should not remain.
This download dialog is a weird one.  It's styled as a modal dialog, but it behaves as a modless one.  If firefox doesn't require, for technical reasons, that you make a decision about what to do before interacting with the page underneath or other parts of the browser, then it should be presented as one of our modeless notification bars (like "remember this password:).  These bars are our way of presenting a user with a decision, but forcing them to make a decision right away if they don't want to, or want to consult the current webpage in order to make a decision.

If, on the other hand, it really is modal for technical reasons, then we should block access to what's going on behind the dialog.

I use the term "technical reasons" throughout this because, from a user's perspective, I don't think this is decision that should have to block all use of the browser.  If we were starting from scratch, I wouldn't want this to be modal.  I know, though, that we inherit certain implementations from desktop firefox that mean we cannot proceed until an answer to a dialog is returned.
(In reply to comment #1)

In that first paragraph, that should be "These bars are
our way of presenting a user with a decision, but _without_ forcing them to make a
decision right away if they don't want to, or want to consult the current
webpage in order to make a decision."
Created attachment 415449 [details] [diff] [review]
patch

Treat the Save As dialog as a popup. Click anywhere off the dialog and it goes away.
Assignee: nobody → mark.finkle
Attachment #415449 - Flags: review?(gavin.sharp)
Attachment #415449 - Flags: review?(gavin.sharp) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/0d54c2e88584

Making the Save As prompt become a notification should be a new bug (if not already filed somewhere)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
(Reporter)

Comment 5

9 years ago
verified FIXED on builds:
Mozilla/5.0 (Windows; U; Window3sCE 5.2; en-US; rv:1.9.2b5pre) Gecko/20091202 Namoroka/3.6b5pre Fennec/1.0a4pre

and

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091202 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091202 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.