cursor set to "crosshair" only shows on moving

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3 (.NET CLR 3.5.30729)

I set the cursor attribute on the root svg element

Reproducible: Always




I had areas with different colors, the result was the same on all of them.
Can you attach a testcase that reproduces the issue for you?
(Reporter)

Comment 2

8 years ago
Created attachment 415491 [details]
See filename. Not reduced. Only cursor attribute on svg root counts
FWIW, this works fine for me in Firefox 3.6b4 (and a mozilla-central nightly) in Ubuntu.  My cursor is a crosshair whenever it's over the attached testcase.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b4pre) Gecko/20091123 Namoroka/3.6b4pre
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091201 Minefield/3.7a1pre

Comment 0 doesn't really describe what's broken at all.  Based on the bug title, I'm guessing that on your machine, you see a normal mouse-pointer when you hover over the testcase (but a crosshair when you move the mouse) -- is that a correct assessment?
(Reporter)

Comment 4

8 years ago
When I'm moving my 'mouse' i see a crosshair cursor.
Whem I'm not moving my 'mouse' i see no cursor (while i expect to see the same crosshair
I just loaded the testcase on Windows XP, in Firefox 3.5 / 3.6 / 3.7, and I don't see this bug there, either.

However, I do see a related issue: I hover over the testcase, and then I alt-tab to another window which covers up Firefox (or at least blocks it from my cursor, and hence changes cursor to normal pointer), and I then alt-tab **back** to Firefox --> the cursor doesn't switch back to a crosshair until I move it.

This issue affects all versions that I tried (Firefox 3.5/3.6/3.7).  It doesn't affect my mozilla-central nightly on Ubuntu.

Maybe the reporter's issue here (on Windows Vista) is a more serious version of the same problem?

Builds that I tested:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b4pre) Gecko/20091124 Namoroka/3.6b4pre (.NET CLR 3.5.30729)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091029 Minefield/3.7a1pre (.NET CLR 3.5.30729)
I tested this on Vista SP2 with:

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b5pre) Gecko/20091201 Namoroka/3.6b5pre

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091201 Minefield/3.7a1pre (.NET CLR 3.5.30729)

and I cannot reproduce the bug either.
(Reporter)

Comment 7

8 years ago
I just had the same thing happening on Opera, so maybe it's an OS bug.
I checked on Vista so I don't think it is an OS bug.
This seems to work fine on Trunk now. Cursor is always a crosshair for me even when tab switching by keyboard without moving the mouse.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.