Update personas_constants.php on sm-personas01.mozilla.org

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
VERIFIED FIXED
9 years ago
3 years ago

People

(Reporter: rdoherty, Assigned: fox2mike)

Tracking

Details

(Reporter)

Description

9 years ago
getpersonas.com will use the same redirection service that AMO uses (outgoing.mozilla.org) and needs the configuration added to server/lib/personas_constants.php on sm-personas01.mozilla.org

These 2 lines need to be added to server/lib/personas_constants.php and the REDIRECT_SECRET_KEY should be changed to the one used on outgoing.mozilla.org:

if (!defined('REDIRECT_SECRET_KEY')) { define('REDIRECT_SECRET_KEY', ''); }
if (!defined('REDIRECT_URL')) { define('REDIRECT_URL', 'http://outgoing.mozilla.org/v1/'); }

I've added them to server/lib/personas_constants.php.dist for reference.

Let me know if there are questions, thanks!
(Reporter)

Updated

9 years ago
Blocks: 521076
(Assignee)

Updated

9 years ago
Assignee: server-ops → shyam
(Assignee)

Comment 1

9 years ago
Done. 

I'd probably try and use outgoing.stage.mozilla.com though, since this is stage and outgoing.m.o is production...but I'll let you take a call on that.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Done. 
> 
> I'd probably try and use outgoing.stage.mozilla.com though, since this is stage
> and outgoing.m.o is production...but I'll let you take a call on that.

Didn't know there was a stage site, but I'd rather not be testing 2 'stage' versions of software against each other. Would make it really hard to debug.
(Reporter)

Comment 3

9 years ago
Re-opening. The link in the persona content on this page: http://sm-personas01.mozilla.org/en-US/persona/827 (http://outgoing.mozilla.org/v1/88054a6cd6406abdbb72bb01b678cae0c073ed2f/http%3A//www.lls.org) gives an 'invalid address' error. 

I've tested this with another instance of the redirector and it works, so my guess is REDIRECT_SECRET_KEY is not correct?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

9 years ago
(In reply to comment #3)

> I've tested this with another instance of the redirector and it works, so my
> guess is REDIRECT_SECRET_KEY is not correct?

Yup, forgot to fill that in. Should be okay now.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

9 years ago
Works, thanks!
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.