Should JSOPTION_ANONFUNFIX be on by default in the shell?

RESOLVED DUPLICATE of bug 595555

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 595555
9 years ago
8 years ago

People

(Reporter: jimb, Assigned: jimb)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Assignee)

Comment 1

9 years ago
I was tracking down why a test I'd written passed under the shell, but failed under jsreftests.  The reason was that I'd used a form like this:

    function(x,y){}

When JSOPTION_ANONFUNFIX is set, this is flagged as a syntax error.  JSOPTION_ANONFUNFIX is set by default in the browser, but cleared by default in the shell.  Is there a rationale for keeping it this way?  It seems to me that, absent some compelling reason, it serves our purpose best for shell and browser to be aligned.

I understand why, for example, 'let' and 'yield' must be disabled by default in the browser, and I think it's correct that they're enabled in the shell.  The shell should reflect the latest and greatest version of the language, and the test harness manages this.  But JSOPTION_ANONFUNFIX seems like a distinct axis, and I don't see why browser and shell should sit at different points on that axis.
I think I just plain forgot to flip the option for the shell when it was set for the browser. Digging... argh, cvs time... Yup, sorry about that:

revision 1.321
date: 2007/04/13 23:06:40;  author: brendan%mozilla.org;  state: Exp;  lines: +1 -0
Set JSOPTION_ANONFUNFIX as one of the default options (377433, r+sr=jst).

No shell change AFAIK. Please do fix this oversight. Thanks,

/be
(Assignee)

Updated

9 years ago
Assignee: general → jim

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595555
You need to log in before you can comment on or make changes to this bug.